eigen: Fix pkg-config file prefix error
authorMatt Flax <flatmax@flatmax.org>
Thu, 16 Aug 2018 22:16:20 +0000 (08:16 +1000)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 17 Aug 2018 17:20:23 +0000 (19:20 +0200)
eigen generates a pkg-config file which has a broken prefix
(@CMAKE_INSTALL_PREFIX@).  This broken prefix causes an incorrect path when
other packages call pkg-config --cflags eigen.

This patch fixes the prefix in the generated eigen pc file, so projects
which depend on this pc file can now correctly find the eigen include
directory at build time.

Also correct the Cflags output to use the runtime prefix instead of the
build time STAGING_DIR, like we do elsewhere.

[Peter: drop backslashes, tweak commit message]
Signed-off-by: Matt Flax <flatmax@flatmax.org>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/eigen/eigen.mk

index 89f54fb9488a5830d5ae3d6dc24df3280e3d4560..27c4e212a97b4cd16c5e5b162971016187847ad2 100644 (file)
@@ -23,7 +23,8 @@ endif
 # Generate the .pc file at build time
 define EIGEN_BUILD_CMDS
        sed -r -e 's,^Version: .*,Version: $(EIGEN_VERSION),' \
-               -e 's,^Cflags: .*,Cflags: -I$(EIGEN_DEST_DIR),' \
+               -e 's,^Cflags: .*,Cflags: -I$$\{prefix\}/include/eigen3,' \
+               -e 's,^prefix.*,prefix=/usr,' \
                $(@D)/eigen3.pc.in >$(@D)/eigen3.pc
 endef