uboot: Add 2011.06, remove 2010.03
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 11 Jul 2011 20:46:17 +0000 (22:46 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 11 Jul 2011 21:44:14 +0000 (23:44 +0200)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
boot/uboot/Config.in
boot/uboot/uboot-2010.03-fix-avr32.patch [deleted file]
boot/uboot/uboot.mk

index dbd4f34dfa9db09b902b423efa47e07228112b01..070533efd7d2b2b1a0dff6f2f444d076fafd71bb 100644 (file)
@@ -12,10 +12,13 @@ config BR2_TARGET_UBOOT_BOARDNAME
 
 choice
        prompt "U-Boot Version"
-       default BR2_TARGET_UBOOT_2011_03
+       default BR2_TARGET_UBOOT_2011_06
        help
          Select the specific U-Boot version you want to use
 
+config BR2_TARGET_UBOOT_2011_06
+       bool "2011.06"
+
 config BR2_TARGET_UBOOT_2011_03
        bool "2011.03"
 
@@ -28,9 +31,6 @@ config BR2_TARGET_UBOOT_2010_09
 config BR2_TARGET_UBOOT_2010_06
        bool "2010.06"
 
-config BR2_TARGET_UBOOT_2010_03
-       bool "2010.03"
-
 config BR2_TARGET_UBOOT_CUSTOM_TARBALL
        bool "Custom tarball"
 
@@ -48,11 +48,11 @@ endif
 
 config BR2_TARGET_UBOOT_VERSION
        string
+       default "2011.06"       if BR2_TARGET_UBOOT_2011_06
        default "2011.03"       if BR2_TARGET_UBOOT_2011_03
        default "2010.12"       if BR2_TARGET_UBOOT_2010_12
        default "2010.09"       if BR2_TARGET_UBOOT_2010_09
        default "2010.06"       if BR2_TARGET_UBOOT_2010_06
-       default "2010.03"       if BR2_TARGET_UBOOT_2010_03
        default "custom"        if BR2_TARGET_UBOOT_CUSTOM_TARBALL
        default $BR2_TARGET_UBOOT_CUSTOM_GIT_VERSION if BR2_TARGET_UBOOT_CUSTOM_GIT
 
diff --git a/boot/uboot/uboot-2010.03-fix-avr32.patch b/boot/uboot/uboot-2010.03-fix-avr32.patch
deleted file mode 100644 (file)
index 1f9aab8..0000000
+++ /dev/null
@@ -1,5 +0,0 @@
-diff -Naur u-boot-2010.03-orig/include/asm-avr32/unaligned.h u-boot-2010.03/include/asm-avr32/unaligned.h
---- u-boot-2010.03-orig/include/asm-avr32/unaligned.h  1969-12-31 21:00:00.000000000 -0300
-+++ u-boot-2010.03/include/asm-avr32/unaligned.h       2010-06-22 23:09:49.000000000 -0300
-@@ -0,0 +1 @@
-+#include <asm-generic/unaligned.h>
index e87727b5dfac5bc22a191ecbbabf4fdd446152aa..ec592e13e4a26a36e8f2cf6d1b12797da134ef24 100644 (file)
@@ -33,11 +33,6 @@ endif
 
 UBOOT_ARCH=$(KERNEL_ARCH)
 
-# u-boot in the past used arch=ppc for powerpc
-ifneq ($(findstring x2010.03,x$(UBOOT_VERSION)),)
-UBOOT_ARCH=$(KERNEL_ARCH:powerpc=ppc)
-endif
-
 UBOOT_CONFIGURE_OPTS += CONFIG_NOSOFTFLOAT=1
 UBOOT_MAKE_OPTS += \
        CROSS_COMPILE="$(CCACHE) $(TARGET_CROSS)" \