projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
f9c5711
)
dbus: fix rebuild if /var/lib is a symlink to /tmp for target
author
Peter Korsgaard
<jacmet@sunsite.dk>
Tue, 21 Apr 2009 15:10:39 +0000
(15:10 -0000)
committer
Peter Korsgaard
<jacmet@sunsite.dk>
Tue, 21 Apr 2009 15:10:39 +0000
(15:10 -0000)
/tmp/dbus will end up being a recursive symlink to itself on the build host.
package/dbus/dbus.mk
patch
|
blob
|
history
diff --git
a/package/dbus/dbus.mk
b/package/dbus/dbus.mk
index b987b1c261473a4ea83cfabb1044788f492dade3..7326b419bb7384972d1a4a813a64407a5c7340eb 100644
(file)
--- a/
package/dbus/dbus.mk
+++ b/
package/dbus/dbus.mk
@@
-50,6
+50,11
@@
endif
$(eval $(call AUTOTARGETS,package,dbus))
+# fix rebuild if /var/lib is a symlink to /tmp
+$(DBUS_HOOK_POST_BUILD): $(DBUS_TARGET_BUILD)
+ rm -rf /tmp/dbus
+ touch $@
+
$(DBUS_HOOK_POST_INSTALL): $(DBUS_TARGET_INSTALL_TARGET)
rm -rf $(TARGET_DIR)/usr/lib/dbus-1.0
rm -rf $(TARGET_DIR)/var/lib/dbus