package/acpid: fix acpid.service permissions
authorJames Hilliard <james.hilliard1@gmail.com>
Wed, 12 Dec 2018 02:20:04 +0000 (10:20 +0800)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 13 Dec 2018 20:58:42 +0000 (21:58 +0100)
Execution permissions cause systemd to throw runtime warnings since
systemd service files are essentially a type of configuration file and
are not designed to be executed like init scripts.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/acpid/acpid.mk

index 514fd31fe6769b23aa00f1a41baaa4b564c15e33..adcc1757aaac79c4c5c61cfbf6dc9a54921bd509 100644 (file)
@@ -11,7 +11,7 @@ ACPID_LICENSE = GPL-2.0+
 ACPID_LICENSE_FILES = COPYING
 
 define ACPID_INSTALL_INIT_SYSTEMD
-       $(INSTALL) -D -m 0755 package/acpid/acpid.service \
+       $(INSTALL) -D -m 0644 package/acpid/acpid.service \
                $(TARGET_DIR)/usr/lib/systemd/system/acpid.service
        mkdir -p $(TARGET_DIR)/etc/systemd/system/multi-user.target.wants
        ln -sf ../../../../usr/lib/systemd/system/acpid.service \