kmod: bump version
authorPeter Korsgaard <peter@korsgaard.com>
Fri, 11 Apr 2014 18:57:27 +0000 (20:57 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 11 Apr 2014 18:57:27 +0000 (20:57 +0200)
And add optional support for the python bindings.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/kmod/kmod.mk

index 46c8ea9357187412eea6ad03286085720aff11f9..398740712cfeeeb0acc91d6c48769e91685ef653 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-KMOD_VERSION = 16
+KMOD_VERSION = 17
 KMOD_SOURCE = kmod-$(KMOD_VERSION).tar.xz
 KMOD_SITE = $(BR2_KERNEL_MIRROR)/linux/utils/kernel/kmod/
 KMOD_INSTALL_STAGING = YES
@@ -32,6 +32,11 @@ KMOD_DEPENDENCIES += xz
 KMOD_CONF_OPT += --with-xz
 endif
 
+ifeq ($(BR2_PACKAGE_PYTHON),y)
+KMOD_DEPENDENCIES += python
+KMOD_CONF_OPT += --enable-python
+endif
+
 # --gc-sections triggers a bug in the current Xtensa binutils
 ifeq ($(BR2_xtensa),y)
 KMOD_CONF_ENV += cc_cv_LDFLAGS__Wl___gc_sections=no