- fix bug #1042; Hardcoding system-paths is a bad idea. If some of them are not
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Sat, 30 Sep 2006 21:08:56 +0000 (21:08 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Sat, 30 Sep 2006 21:08:56 +0000 (21:08 -0000)
  in PATH seen by make then most likely for a very good reason. Set your PATH accordingly if you need /bin or /usr/local/bin et al.

package/Makefile.in

index 2346882986a4d067e962c74d89c435a0d945fef5..9cd170ddf32a1f3db09b904bcbb6ec8e78133819 100644 (file)
@@ -44,7 +44,7 @@ GNU_TARGET_SUFFIX:=-$(strip $(subst ",, $(BR2_GNU_TARGET_SUFFIX)))
 # Strip off the annoying quoting
 STAGING_DIR:=$(strip $(subst ",, $(BR2_STAGING_DIR)))
 #"
-TARGET_PATH=$(STAGING_DIR)/bin:$(TOOL_BUILD_DIR)/bin:/bin:/sbin:/usr/bin:/usr/sbin:$(PATH)
+TARGET_PATH=$(STAGING_DIR)/bin:$(TOOL_BUILD_DIR)/bin:$(PATH)
 IMAGE:=$(BASE_DIR)/rootfs.$(ARCH)$(ARCH_FPU_SUFFIX)
 REAL_GNU_TARGET_NAME=$(OPTIMIZE_FOR_CPU)$(GNU_TARGET_SUFFIX)
 GNU_TARGET_NAME=$(OPTIMIZE_FOR_CPU)-linux