fs/iso9660: add dependencies for make source
authorKaroly Kasza <kaszak@gmail.com>
Sat, 18 Oct 2014 18:23:59 +0000 (20:23 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 19 Oct 2014 09:52:32 +0000 (11:52 +0200)
The "iso image" rootfs target is a special one, as it does not use the
ROOTFS_TARGET infrastructure. The absence of ROOTFS_*_DEPENDENCIES
variable makes "make source" to skip this target's dependencies
(namely host-cdrkit and it's children) obstructing an offline build.

[Thomas: add the rootfs-iso9660-show-depends target, so that 'make
graph-depends' doesn't break when iso9660 is selected.]

Signed-off-by: Karoly Kasza <kaszak@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
fs/iso9660/iso9660.mk

index b0e755db94dcade4c443a6fa3729182dfc2d949f..908f0e981ebac16d4e60720867f85c402cd57d0e 100644 (file)
@@ -10,7 +10,9 @@
 ISO9660_TARGET_DIR = $(BUILD_DIR)/iso9660
 ISO9660_BOOT_MENU := $(call qstrip,$(BR2_TARGET_ROOTFS_ISO9660_BOOT_MENU))
 
-$(BINARIES_DIR)/rootfs.iso9660: host-cdrkit host-fakeroot linux rootfs-cpio grub
+ROOTFS_ISO9660_DEPENDENCIES = grub host-cdrkit host-fakeroot linux rootfs-cpio
+
+$(BINARIES_DIR)/rootfs.iso9660: $(ROOTFS_ISO9660_DEPENDENCIES)
        @$(call MESSAGE,"Generating root filesystem image rootfs.iso9660")
        mkdir -p $(ISO9660_TARGET_DIR)
        mkdir -p $(ISO9660_TARGET_DIR)/boot/grub
@@ -41,6 +43,9 @@ endif
 
 rootfs-iso9660: $(BINARIES_DIR)/rootfs.iso9660
 
+rootfs-iso9660-show-depends:
+       @echo $(ROOTFS_ISO9660_DEPENDENCIES)
+
 ################################################################################
 #
 # Toplevel Makefile options