ruby: really disable ncurses/readline for host
authorPeter Korsgaard <jacmet@sunsite.dk>
Sun, 27 Nov 2011 21:16:40 +0000 (22:16 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 27 Nov 2011 21:16:40 +0000 (22:16 +0100)
Commit 150124b (ruby: fix host build breakage) tried to fix host-ruby
build failures by disabling ncurses/readline extensions, but the
ruby configure script doesn't understand --without-ncurses /
--without-readline arguments, so the commit didn't do anything.

Fix it by really disabling them using the --with-out-ext argument.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/ruby/ruby.mk

index ad791f8f4ededd3050bf8ef44f74ee1d615e90ff..d99fd1ee5ad04aca645ba8539e92d0bad9b25fbd 100644 (file)
@@ -11,7 +11,7 @@ HOST_RUBY_AUTORECONF = YES
 RUBY_DEPENDENCIES = host-ruby
 RUBY_MAKE_ENV = $(TARGET_MAKE_ENV)
 RUBY_CONF_OPT = --disable-install-doc --disable-rpath
-HOST_RUBY_CONF_OPT = --disable-install-doc --without-ncurses --without-readline
+HOST_RUBY_CONF_OPT = --disable-install-doc --with-out-ext=curses,readline
 
 # Force optionals to build before we do
 ifeq ($(BR2_PACKAGE_BERKELEYDB),y)