package/wine: host-wine also needs bison and flex
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 11 Dec 2018 16:28:30 +0000 (17:28 +0100)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 11 Dec 2018 22:00:22 +0000 (23:00 +0100)
Just like the build of the target wine, the build of host wine also
needs bison and flex, otherwise the build fails with:

checking for flex... no
configure: error: no suitable flex found. Please install the 'flex' package.

(and similarly for bison once host-flex is provided)

This was detected using per-package directories. It used to "work"
because host-wine comes alphabetically after host-flex and host-bison,
which are dependencies of target wine.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/wine/wine.mk

index dc559efd957f0c70ce5f966a48b03a8b1579c2fe..78c8e6ab630c3cbb1840bb1f78afb780b77833e7 100644 (file)
@@ -10,6 +10,7 @@ WINE_SITE = https://dl.winehq.org/wine/source/3.0
 WINE_LICENSE = LGPL-2.1+
 WINE_LICENSE_FILES = COPYING.LIB LICENSE
 WINE_DEPENDENCIES = host-bison host-flex host-wine
+HOST_WINE_DEPENDENCIES = host-bison host-flex
 
 # Wine needs its own directory structure and tools for cross compiling
 WINE_CONF_OPTS = \