boot/arm-trusted-firmware: add pattern based image copy for ATF
authorSchenk Michael <michael.schenk@noser.com>
Fri, 15 Nov 2019 07:51:01 +0000 (07:51 +0000)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 15 Nov 2019 20:29:54 +0000 (21:29 +0100)
This adds support for different platforms where the binaries have
different extensions.

Signed-off-by: Michael Schenk <michael.schenk@noser.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
boot/arm-trusted-firmware/Config.in
boot/arm-trusted-firmware/arm-trusted-firmware.mk

index beb95fbf063aaee21ff57e2a491043365815518d..78c03019d527d1e3aa9681ea882706757309a748 100644 (file)
@@ -135,4 +135,11 @@ config BR2_TARGET_ARM_TRUSTED_FIRMWARE_DEBUG
        help
          Enable this option to build ATF with DEBUG=1.
 
+config BR2_TARGET_ARM_TRUSTED_FIRMWARE_IMAGES
+       string "Binary boot images"
+       default "*.bin"
+       help
+         Names of generated image files that are installed in the
+         output images/ directory.
+
 endif
index a7814e534a705b2b71e762f42be4f59af949d5af..e528686aa1f3ef24c3aeeeab26094ec1d17453da 100644 (file)
@@ -146,7 +146,9 @@ define ARM_TRUSTED_FIRMWARE_BUILD_CMDS
 endef
 
 define ARM_TRUSTED_FIRMWARE_INSTALL_IMAGES_CMDS
-       cp -dpf $(ARM_TRUSTED_FIRMWARE_IMG_DIR)/*.bin $(BINARIES_DIR)/
+       $(foreach f,$(call qstrip,$(BR2_TARGET_ARM_TRUSTED_FIRMWARE_IMAGES)), \
+               cp -dpf $(ARM_TRUSTED_FIRMWARE_IMG_DIR)/$(f) $(BINARIES_DIR)/
+       )
        $(ARM_TRUSTED_FIRMWARE_BL31_UBOOT_INSTALL)
        $(ARM_TRUSTED_FIRMWARE_BL31_UBOOT_INSTALL_ELF)
 endef