package/qt5/qt5coap: new package
authorAngelo Compagnucci <angelo@amarulasolutions.com>
Tue, 24 Nov 2020 06:59:15 +0000 (07:59 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 5 Dec 2020 21:49:12 +0000 (22:49 +0100)
The Qt CoAP module implements the client side of CoAP defined by RFC
7252.

Signed-off-by: Angelo Compagnucci <angelo@amarulasolutions.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/qt5/Config.in
package/qt5/qt5coap/Config.in [new file with mode: 0644]
package/qt5/qt5coap/qt5coap.hash [new file with mode: 0644]
package/qt5/qt5coap/qt5coap.mk [new file with mode: 0644]

index b839a0d113bcaab4d432d44dd29c508330e6855f..d70f4c2b0427f86aca45b637088542d9d0f5c82d 100644 (file)
@@ -169,6 +169,7 @@ F:  package/python-pillow/
 F:     package/python-pydal/
 F:     package/python-spidev/
 F:     package/python-web2py/
+F:     package/qt5/qt5coap/
 F:     package/sam-ba/
 F:     package/sshguard/
 F:     package/sunwait/
index fc0e68e8b744a4db127094cb653d52832574fb99..9431f4980d4349091fcea6b0dc1f63bf9541fa30 100644 (file)
@@ -40,6 +40,7 @@ if BR2_PACKAGE_QT5
 source "package/qt5/qt53d/Config.in"
 source "package/qt5/qt5base/Config.in"
 source "package/qt5/qt5charts/Config.in"
+source "package/qt5/qt5coap/Config.in"
 source "package/qt5/qt5connectivity/Config.in"
 source "package/qt5/qt5declarative/Config.in"
 source "package/qt5/qt5enginio/Config.in"
diff --git a/package/qt5/qt5coap/Config.in b/package/qt5/qt5coap/Config.in
new file mode 100644 (file)
index 0000000..b5bed34
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_QT5COAP
+       bool "qt5coap"
+       help
+         Qt is a cross-platform application and UI framework for
+         developers using C++.
+
+         CoAP is a protocol for IoT devices, and machine to machine
+         communication. The Qt CoAP module implements the client side
+         of CoAP defined by RFC 7252.
+
+         https://doc.qt.io/QtCoAP/qtcoap-index.html
diff --git a/package/qt5/qt5coap/qt5coap.hash b/package/qt5/qt5coap/qt5coap.hash
new file mode 100644 (file)
index 0000000..29d9595
--- /dev/null
@@ -0,0 +1,6 @@
+# Hash locally calculated
+sha256  f2addd89e94fb3945fc6ee6db795b0736cd3396760b31e04c01cd02558c53e07  qt5coap-5.15.1.tar.gz
+
+# Hashes for license files:
+sha256  8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903  LICENSE.GPL3
+sha256  f827ad079686ba92cc94811e35492d0e8966f704008b6da9eeda0b659fb58a8d  LICENSE.FDL
diff --git a/package/qt5/qt5coap/qt5coap.mk b/package/qt5/qt5coap/qt5coap.mk
new file mode 100644 (file)
index 0000000..c1666f2
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# qt5coap
+#
+################################################################################
+
+QT5COAP_VERSION = $(QT5_VERSION)
+QT5COAP_SITE = $(call github,qt,qtcoap,v$(QT5_VERSION))
+QT5COAP_INSTALL_STAGING = YES
+QT5COAP_LICENSE = GPL-3.0, GFDL-1.3
+QT5COAP_LICENSE_FILES = LICENSE.GPL3 LICENSE.FDL
+QT5COAP_SYNC_QT_HEADERS = YES
+
+$(eval $(qmake-package))