ltrace: Removes the libelf dependency
authorGregory CLEMENT <gregory.clement@free-electrons.com>
Thu, 28 Aug 2014 12:21:31 +0000 (14:21 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 13 Sep 2014 21:56:56 +0000 (23:56 +0200)
The libelf is currently provided by 2 packages libelf and
elfutils. The first package provides an old version of the libelf
which is no more compatible with a recent version of ltrace. This
patch removes the dependency on the libelf package and only keep the
elfuils package which provides the accurate version of libelf for
ltrace.

It will also allow to remove the libelf package and to avoid conflicts
with two packages providing the same library.

Signed-off-by: Gregory CLEMENT <gregory.clement@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ltrace/Config.in
package/ltrace/ltrace.mk

index 8cabfa2354bac4a5582191909a46ea28566ab885..dc759d84c67300100c2e292745577ee82747ccd3 100644 (file)
@@ -6,7 +6,6 @@ config BR2_PACKAGE_LTRACE
        # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=756764.
        depends on (BR2_i386 || BR2_arm \
                || BR2_powerpc || BR2_sparc || BR2_x86_64)
-       select BR2_PACKAGE_LIBELF
        select BR2_PACKAGE_ELFUTILS
        depends on BR2_LARGEFILE # elfutils
        depends on BR2_USE_WCHAR # elfutils
index 0a3a90c344c1e933dc761c25b7ad8f4e0a48fcd0..48bf7bd5b6906f01066d83d978137b7e8a7333b9 100644 (file)
@@ -6,7 +6,7 @@
 
 LTRACE_VERSION = 0896ce554f80afdcba81d9754f6104f863dea803
 LTRACE_SITE = git://anonscm.debian.org/collab-maint/ltrace.git
-LTRACE_DEPENDENCIES = libelf elfutils
+LTRACE_DEPENDENCIES = elfutils
 LTRACE_CONF_OPT = --disable-werror
 LTRACE_LICENSE = GPLv2
 LTRACE_LICENSE_FILES = COPYING