package/pkg-meson.mk: fix deprecation warnings in cross-compilation.conf
authorGleb Mazovetskiy <glex.spb@gmail.com>
Sun, 27 Dec 2020 02:15:05 +0000 (02:15 +0000)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 28 Dec 2020 21:49:50 +0000 (22:49 +0100)
As of meson 0.56.0, `<lang>_args` and `<lang>_link_args` in the
`[properties]` section are deprecated and should be placed in the
`[built-in options]` section instead.

Source: https://mesonbuild.com/Machine-files.html#properties

Fixes the following deprecation warnings:

> DEPRECATION: c_args in the [properties] section of the machine file is deprecated, use the [built-in options] section.
> DEPRECATION: c_link_args in the [properties] section of the machine file is deprecated, use the [built-in options] section.
> DEPRECATION: cpp_args in the [properties] section of the machine file is deprecated, use the [built-in options] section.
> DEPRECATION: cpp_link_args in the [properties] section of the machine file is deprecated, use the [built-in options] section.

Signed-off-by: Gleb Mazovetskiy <glex.spb@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/meson/cross-compilation.conf.in

index 1880051315c0655271b536b070c56557ac03f328..37b49eea3b651e2f79b3c07637e681db34c252ab 100644 (file)
@@ -12,12 +12,14 @@ pkgconfig = '@HOST_DIR@/bin/pkgconf'
 g-ir-compiler = '@STAGING_DIR@/usr/bin/g-ir-compiler'
 g-ir-scanner = '@STAGING_DIR@/usr/bin/g-ir-scanner'
 
-[properties]
-needs_exe_wrapper = true
+[built-in options]
 c_args = [@TARGET_CFLAGS@]
 c_link_args = [@TARGET_LDFLAGS@]
 cpp_args = [@TARGET_CXXFLAGS@]
 cpp_link_args = [@TARGET_LDFLAGS@]
+
+[properties]
+needs_exe_wrapper = true
 sys_root = '@STAGING_DIR@'
 pkg_config_libdir = '@STAGING_DIR@/usr/lib/pkgconfig:@STAGING_DIR@/usr/share/pkgconfig'
 pkg_config_static = '@STATIC@'