package/vlc: add optional support for minizip
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 28 Feb 2016 20:18:26 +0000 (21:18 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 5 Mar 2016 14:02:15 +0000 (15:02 +0100)
When minizip was compiled before, vlc will use it as optional
dependency:

$ output/host/usr/bin/x86_64-linux-readelf -a output/target/usr/lib/vlc/plugins/access/libzip_plugin.so | grep NEEDED | sort
 0x0000000000000001 (NEEDED)             Shared library: [libc.so.1]
 0x0000000000000001 (NEEDED)             Shared library: [libdl.so.1]
 0x0000000000000001 (NEEDED)             Shared library: [libintl.so.8]
 0x0000000000000001 (NEEDED)             Shared library: [libminizip.so.1]
[...]

The build system offers no option to en-/disable minizip support,
the same is valid for zlib support:
https://git.videolan.org/?p=vlc.git;a=blob;f=configure.ac;h=be658816bcda642090e1cff20d93e61b25299250;hb=HEAD#l831

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/vlc/vlc.mk

index 4f8bf7296ed0caa0645a30a91759643baff6970d..bf1ec450584830466593761a1c35275afcd0178f 100644 (file)
@@ -336,6 +336,10 @@ else
 VLC_CONF_OPTS += --disable-lua
 endif
 
+ifeq ($(BR2_PACKAGE_MINIZIP),y)
+VLC_DEPENDENCIES += minizip
+endif
+
 ifeq ($(BR2_PACKAGE_QT_GUI_MODULE),y)
 VLC_CONF_OPTS += --enable-qt
 VLC_CONF_ENV += \