Revert "package/sdl2: disable altivec built-in function for PowerPC"
authorRomain Naour <romain.naour@gmail.com>
Sat, 25 Mar 2017 21:59:01 +0000 (22:59 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 15 Apr 2017 10:16:15 +0000 (12:16 +0200)
The bug discovered while packaging supertux is now fixed by the previous
patch but the issue can still be present in other C++11 package if
-std=c++11 is used on PPC with Altivec vectorization.

This reverts commit d2903aaf1314b50a8a10ce937d2b33c5c42e463e.

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/sdl2/sdl2.mk

index 1db4e76311bfa58f391486831c519b941b565aea..f8a31960d0722a848cb5beb11a471e9c1b971ac9 100644 (file)
@@ -23,16 +23,6 @@ SDL2_CONF_OPTS += \
 # We must enable static build to get compilation successful.
 SDL2_CONF_OPTS += --enable-static
 
-# From https://bugs.debian.org/cgi-bin/bugreport.cgi/?bug=770670
-# "The problem lies within SDL_cpuinfo.h.  It includes altivec.h, which by
-# definition provides an unconditional vector, pixel and bool define in
-# standard-c++ mode.  In GNU-c++ mode this names are only defined
-# context-sensitive by cpp.  SDL_cpuinfo.h is included by SDL.h.
-# Including altivec.h makes arbitrary code break."
-ifeq ($(BR2_POWERPC_CPU_HAS_ALTIVEC),y)
-SDL2_CONF_OPTS += --disable-altivec
-endif
-
 ifeq ($(BR2_PACKAGE_HAS_UDEV),y)
 SDL2_DEPENDENCIES += udev
 SDL2_CONF_OPTS += --enable-libudev