package/python-pytest: new package
authorMarcin Niestroj <m.niestroj@grinn-global.com>
Tue, 1 Sep 2020 17:16:44 +0000 (19:16 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 6 Sep 2020 12:44:16 +0000 (14:44 +0200)
Signed-off-by: Marcin Niestroj <m.niestroj@grinn-global.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/python-pytest/Config.in [new file with mode: 0644]
package/python-pytest/python-pytest.hash [new file with mode: 0644]
package/python-pytest/python-pytest.mk [new file with mode: 0644]

index 34f545b6cf228b03a90582ea79c9fa7147852d63..c85dd355d422cc56bae851eda337e8e6b1ed73ca 100644 (file)
@@ -1628,6 +1628,7 @@ F:        package/python-ansicolors/
 F:     package/python-iniconfig/
 F:     package/python-packaging/
 F:     package/python-pluggy/
+F:     package/python-pytest/
 F:     package/rs485conf/
 F:     package/turbolua/
 F:     support/testing/tests/package/test_netdata.py
index 928405df61073b1f364024dc74c3f41929e50fdc..90d7908eab9660cdfaca86d2908138606eae1390 100644 (file)
@@ -1121,6 +1121,7 @@ menu "External python modules"
        source "package/python-pysocks/Config.in"
        source "package/python-pytablereader/Config.in"
        source "package/python-pytablewriter/Config.in"
+       source "package/python-pytest/Config.in"
        source "package/python-pytrie/Config.in"
        source "package/python-pytz/Config.in"
        source "package/python-pyudev/Config.in"
diff --git a/package/python-pytest/Config.in b/package/python-pytest/Config.in
new file mode 100644 (file)
index 0000000..ad57547
--- /dev/null
@@ -0,0 +1,16 @@
+config BR2_PACKAGE_PYTHON_PYTEST
+       bool "python-pytest"
+       depends on BR2_PACKAGE_PYTHON3
+       select BR2_PACKAGE_PYTHON_ATTRS # runtime
+       select BR2_PACKAGE_PYTHON_INICONFIG # runtime
+       select BR2_PACKAGE_PYTHON_MORE_ITERTOOLS # runtime
+       select BR2_PACKAGE_PYTHON_PACKAGING # runtime
+       select BR2_PACKAGE_PYTHON_PLUGGY # runtime
+       select BR2_PACKAGE_PYTHON_PY # runtime
+       select BR2_PACKAGE_PYTHON_TOML # runtime
+       help
+         pytest is a framework that makes building simple and scalable
+         tests easy. Tests are expressive and readable—no boilerplate
+         code required.
+
+         https://docs.pytest.org/en/latest/
diff --git a/package/python-pytest/python-pytest.hash b/package/python-pytest/python-pytest.hash
new file mode 100644 (file)
index 0000000..6f3532a
--- /dev/null
@@ -0,0 +1,5 @@
+# md5, sha256 from https://pypi.org/pypi/pytest/json
+md5    c3e7c811b2b74c60bb5fb951229ebce9  pytest-6.0.1.tar.gz
+sha256 85228d75db9f45e06e57ef9bf4429267f81ac7c0d742cc9ed63d09886a9fe6f4  pytest-6.0.1.tar.gz
+# Locally computer sha256
+sha256 7898b9b164d4f93fd9a562fd0f592935518b48c4745303964110eb7f7fe64faf  LICENSE
diff --git a/package/python-pytest/python-pytest.mk b/package/python-pytest/python-pytest.mk
new file mode 100644 (file)
index 0000000..c17d579
--- /dev/null
@@ -0,0 +1,15 @@
+################################################################################
+#
+# python-pytest
+#
+################################################################################
+
+PYTHON_PYTEST_VERSION = 6.0.1
+PYTHON_PYTEST_SOURCE = pytest-$(PYTHON_PYTEST_VERSION).tar.gz
+PYTHON_PYTEST_SITE = https://files.pythonhosted.org/packages/20/4c/d7b19b8661be78461fff0392e33943784340424921578fe1bf300ef59831
+PYTHON_PYTEST_SETUP_TYPE = setuptools
+PYTHON_PYTEST_LICENSE = MIT
+PYTHON_PYTEST_LICENSE_FILES = LICENSE
+PYTHON_PYTEST_DEPENDENCIES = host-python-setuptools-scm
+
+$(eval $(python-package))