arch: remove sh2, sh3 and sh3eb support
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Feb 2014 14:25:34 +0000 (15:25 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 5 Feb 2014 11:05:58 +0000 (12:05 +0100)
This patch removes the sh2, sh3 and sh3eb support, because the user
base is inexistent, and the Linux support for these architectures is
poor. The sh2a support is preserved, because at least one user
expressed interest in this architecture, and is actually using it:

  http://lists.busybox.net/pipermail/buildroot/2013-April/070399.html

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Config.in.legacy
arch/Config.in.sh
package/kexec/Config.in
package/mplayer/Config.in
package/qemu/qemu.mk
package/uclibc/Config.in

index 89181843be411296093f7dd6e542bb5585ca5f1b..2fe9cf9ecfd40a4a512b550b1deee28ed89cde7f 100644 (file)
@@ -101,6 +101,24 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2014.02"
 
+config BR2_sh2
+       bool "sh2 support removed"
+       help
+         Due to an inexistent user base and generally poor Linux
+         support, the support for the SH2 architecture was removed.
+
+config BR2_sh3
+       bool "sh3 support removed"
+       help
+         Due to an inexistent user base and generally poor Linux
+         support, the support for the SH3 architecture was removed.
+
+config BR2_sh3eb
+       bool "sh3eb support removed"
+       help
+         Due to an inexistent user base and generally poor Linux
+         support, the support for the SH3eb architecture was removed.
+
 config BR2_PACKAGE_LZMA
        bool "lzma target package has been removed"
        select BR2_LEGACY
index 10d4ef605776282afe46a488d809f6f03990b40a..1bdea37cbc550601bc7f088e5b1951eca8b1bd87 100644 (file)
@@ -5,14 +5,8 @@ choice
        help
          Specific CPU variant to use
 
-config BR2_sh2
-       bool "sh2 (SH2 big endian)"
 config BR2_sh2a
        bool "sh2a (SH2A big endian)"
-config BR2_sh3
-       bool "sh3 (SH3 little endian)"
-config BR2_sh3eb
-       bool "sh3eb (SH3 big endian)"
 config BR2_sh4
        bool "sh4 (SH4 little endian)"
 config BR2_sh4eb
@@ -24,10 +18,7 @@ config BR2_sh4aeb
 endchoice
 
 config BR2_ARCH
-       default "sh2"           if BR2_sh2
        default "sh2a"          if BR2_sh2a
-       default "sh3"           if BR2_sh3
-       default "sh3eb"         if BR2_sh3eb
        default "sh4"           if BR2_sh4
        default "sh4eb"         if BR2_sh4eb
        default "sh4a"          if BR2_sh4a
@@ -35,7 +26,5 @@ config BR2_ARCH
        default "sh64"          if BR2_sh64
 
 config BR2_ENDIAN
-       default "LITTLE"        if BR2_sh3 || BR2_sh4 || BR2_sh4a || \
-                                  BR2_sh64
-       default "BIG"           if BR2_sh2 || BR2_sh2a || BR2_sh3eb || \
-                                  BR2_sh4eb || BR2_sh4aeb
+       default "LITTLE"        if BR2_sh4 || BR2_sh4a || BR2_sh64
+       default "BIG"           if BR2_sh2a || BR2_sh4eb || BR2_sh4aeb
index 955a5f4dce787d37b0be9b1f4dbda48b46ee358f..0139c17b86bd9c152dc53cfc20e9316221c62880 100644 (file)
@@ -2,7 +2,7 @@ config BR2_PACKAGE_KEXEC
        bool "kexec"
        depends on BR2_i386 || BR2_x86_64 || BR2_arm || BR2_armeb || \
                BR2_mips || BR2_mips64 || BR2_mipsel || BR2_mips64el || \
-               BR2_powerpc || BR2_sh4 || BR2_sh4a || BR2_sh3
+               BR2_powerpc || BR2_sh4 || BR2_sh4a
        help
          Kexec is a user space utiltity for loading another kernel
          and asking the currently running kernel to do something with it.
index c8f1480883dc4ab2ac93ab7b6bef86628117dc9a..ae273e4f804c985d1d0578e2e7012b98616668b8 100644 (file)
@@ -1,7 +1,7 @@
 config BR2_PACKAGE_MPLAYER
        bool "mplayer"
        # Those architectures are not supported by MPlayer
-       depends on !(BR2_sh2 || BR2_sh2a || BR2_sh4a || BR2_sh4aeb \
+       depends on !(BR2_sh2a || BR2_sh4a || BR2_sh4aeb \
                        || BR2_microblaze || BR2_aarch64 || BR2_nios2)
        # Broken support for <ARMv5
        depends on !(BR2_arm7tdmi || BR2_arm720t || BR2_arm920t \
index a89bf7d20c5893a652e639b3fba0f2c9be90186a..093ae64c0e97b83a97da99a0f000658195a35dd0 100644 (file)
@@ -36,10 +36,7 @@ HOST_QEMU_DEPENDENCIES = host-pkgconf host-zlib host-libglib2 host-pixman
 #       mips64          ?
 #       mips64el        ?
 #       powerpc         ppc
-#       sh2             not supported
 #       sh2a            not supported
-#       sh3             not supported
-#       sh3eb           not supported
 #       sh4             sh4
 #       sh4eb           sh4eb
 #       sh4a            ?
index 77756e3ab238b96c1007a5d04d8ddac7976e3d74..0565ee986c2fb419ffd4b6ee72e07d0b53d4972c 100644 (file)
@@ -241,7 +241,6 @@ config BR2_UCLIBC_SH_TYPE
        string
        depends on BR2_UCLIBC_TARGET_ARCH = "sh"
        default SH2A if BR2_sh2a
-       default SH3  if BR2_sh3 || BR2_sh3eb
        default SH4  if BR2_sh4 || BR2_sh4eb
 
 config BR2_UCLIBC_SPARC_TYPE