package/gr-osmosdr: bump to 0.2.0
authorGwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
Sat, 11 Apr 2020 09:33:53 +0000 (11:33 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 12 Apr 2020 11:49:45 +0000 (13:49 +0200)
gr-osmosdr is now python3 only, so drop everything related to python2.
python-cheetah is no longer mandatory, so drop this too.

Signed-off-by: Gwenhael Goavec-Merou <gwenhael.goavec-merou@trabucayre.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gr-osmosdr/Config.in
package/gr-osmosdr/gr-osmosdr.hash
package/gr-osmosdr/gr-osmosdr.mk

index 1e80137f3532971da5dc337607b5831bd8c42858..a38082af9863830d3b576e7422f19532e16bfa8b 100644 (file)
@@ -14,6 +14,7 @@ if BR2_PACKAGE_GR_OSMOSDR
 config BR2_PACKAGE_GR_OSMOSDR_PYTHON
        bool "python support"
        depends on BR2_PACKAGE_GNURADIO_PYTHON
+       depends on BR2_PACKAGE_PYTHON3
        help
          Enable Python support
 
index 4a1e56abae042126cff21d29c62a850a25cc0f7e..64959c8e744f50289c41511c8f5eb8c88e045563 100644 (file)
@@ -1,3 +1,3 @@
 # Locally calculated:
-sha256 48f92dc02b86ce6d299b35db249f2c8099bb45326c979b6225a020a4188e4204 gr-osmosdr-46698a67e7e06419eefaf45c95129c0c12669045.tar.gz
+sha256 9812429d97bc54f0a8917b880ca9e7e2421c66aeaac8ce5608161a8ae7007122 gr-osmosdr-0.2.0.tar.gz
 sha256 8ceb4b9ee5adedde47b31e975c1d90c73ad27b6b165a1dcd80c7c545eb65b903 COPYING
index fcc817fe854078df129609b62c383666fdca5b1a..c5d6ddc2e27913eb64c01fbd7ed2344487c5b345 100644 (file)
@@ -4,15 +4,15 @@
 #
 ################################################################################
 
-GR_OSMOSDR_VERSION = 46698a67e7e06419eefaf45c95129c0c12669045
-GR_OSMOSDR_SITE = $(call github,osmocom,gr-osmosdr,$(GR_OSMOSDR_VERSION))
+GR_OSMOSDR_VERSION = 0.2.0
+GR_OSMOSDR_SITE = $(call github,osmocom,gr-osmosdr,v$(GR_OSMOSDR_VERSION))
 GR_OSMOSDR_LICENSE = GPL-3.0+
 GR_OSMOSDR_LICENSE_FILES = COPYING
 
 # gr-osmosdr prevents doing an in-source-tree build
 GR_OSMOSDR_SUPPORTS_IN_SOURCE_BUILD = NO
 
-GR_OSMOSDR_DEPENDENCIES = gnuradio host-python-cheetah
+GR_OSMOSDR_DEPENDENCIES = gnuradio host-python3
 
 GR_OSMOSDR_CONF_OPTS = \
        -DENABLE_DEFAULT=OFF \
@@ -24,7 +24,7 @@ GR_OSMOSDR_INSTALL_STAGING = YES
 
 ifeq ($(BR2_PACKAGE_GR_OSMOSDR_PYTHON),y)
 GR_OSMOSDR_CONF_OPTS += -DENABLE_PYTHON=ON
-GR_OSMOSDR_DEPENDENCIES += $(if $(BR2_PACKAGE_PYTHON3),python3,python)
+GR_OSMOSDR_DEPENDENCIES += python3
 else
 GR_OSMOSDR_CONF_OPTS += -DENABLE_PYTHON=OFF
 endif