fs/tar: use qstrip to clean up build output
authorThomas De Schampheleire <patrickdepinguin@gmail.com>
Thu, 22 May 2014 12:35:41 +0000 (14:35 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 28 May 2014 19:19:58 +0000 (21:19 +0200)
When using the tar filesystem method, the build output shows at the end:

echo " tar -c""f <br>/output/images/rootfs.tar -C <br>/output/target ." >>
                                    <br>/output/build/_fakeroot.fs

The inner set of quotes can be easily removed by properly stripping the tar
options (coming from the buildroot configuration).

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Acked-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
fs/tar/tar.mk

index c93888cd56f4632522ce9732ab3bcd6498fc0c3e..f876d03f56da7bad3f447e973d98f223b2d41976 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-TAR_OPTS := $(BR2_TARGET_ROOTFS_TAR_OPTIONS)
+TAR_OPTS := $(call qstrip,$(BR2_TARGET_ROOTFS_TAR_OPTIONS))
 
 define ROOTFS_TAR_CMD
  tar -c$(TAR_OPTS)f $@ -C $(TARGET_DIR) .