nginx-dav-ext: new package
authorJohan Oudinet <johan.oudinet@gmail.com>
Tue, 29 Nov 2016 16:47:51 +0000 (17:47 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 4 Dec 2016 22:33:40 +0000 (23:33 +0100)
Nginx built-in support for webdav is missing support for two commands:
PROPFIND and OPTIONS. This commit adds a new package that provides an
external nginx module with improved webdav support.

Signed-off-by: Johan Oudinet <johan.oudinet@gmail.com>
[Thomas:
 - Remove the BR2_PACKAGE_NGINX_HTTP_DAV_EXT_MODULE sub-option of the
   nginx package. The BR2_PACKAGE_NGINX_DAV_EXT option is sufficient.
 - Move the nginx.mk code together with another external module being
   enabled, nginx-upload.
 - Add LICENSE and LICENSE_FILES variables.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/nginx-dav-ext/Config.in [new file with mode: 0644]
package/nginx-dav-ext/nginx-dav-ext.hash [new file with mode: 0644]
package/nginx-dav-ext/nginx-dav-ext.mk [new file with mode: 0644]
package/nginx/nginx.mk

index ecb8afb60a25c6303e12a2c1a74f9907b2c95839..664d0d96e123745e558f81a3523260e72c6b1f40 100644 (file)
@@ -1545,6 +1545,7 @@ menu "Networking applications"
        source "package/nginx/Config.in"
 if BR2_PACKAGE_NGINX
 menu "External nginx modules"
+       source "package/nginx-dav-ext/Config.in"
        source "package/nginx-naxsi/Config.in"
        source "package/nginx-upload/Config.in"
 endmenu
diff --git a/package/nginx-dav-ext/Config.in b/package/nginx-dav-ext/Config.in
new file mode 100644 (file)
index 0000000..bf197dc
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_NGINX_DAV_EXT
+       bool "nginx-dav-ext"
+       select BR2_PACKAGE_EXPAT
+       help
+         NGINX WebDAV missing commands support (PROPFIND & OPTIONS).
+
+         https://github.com/arut/nginx-dav-ext-module
diff --git a/package/nginx-dav-ext/nginx-dav-ext.hash b/package/nginx-dav-ext/nginx-dav-ext.hash
new file mode 100644 (file)
index 0000000..ea7eb86
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally computed
+sha256 d428a0236c933779cb40ac8c91afb19d5c25a376dc3caab825bfd543e1ee530d  nginx-dav-ext-v0.0.3.tar.gz
diff --git a/package/nginx-dav-ext/nginx-dav-ext.mk b/package/nginx-dav-ext/nginx-dav-ext.mk
new file mode 100644 (file)
index 0000000..61e5bd0
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# nginx-dav-ext
+#
+################################################################################
+
+NGINX_DAV_EXT_VERSION = v0.0.3
+NGINX_DAV_EXT_SITE = $(call github,arut,nginx-dav-ext-module,$(NGINX_DAV_EXT_VERSION))
+NGINX_DAV_EXT_LICENSE = BSD-2c
+NGINX_DAV_EXT_LICENSE_FILES = ngx_http_dav_ext_module.c
+NGINX_DAV_EXT_DEPENDENCIES = expat
+
+$(eval $(generic-package))
index 656362788f6104cb9e8e5c8ee8ce5bd5e0a512c3..79cc4ed3e3f7e6dde696fb5c9c4a15e83dac44ff 100644 (file)
@@ -245,6 +245,11 @@ NGINX_CONF_OPTS += $(addprefix --add-module=,$(NGINX_UPLOAD_DIR))
 NGINX_DEPENDENCIES += nginx-upload
 endif
 
+ifeq ($(BR2_PACKAGE_NGINX_DAV_EXT),y)
+NGINX_CONF_OPTS += --add-module=$(NGINX_DAV_EXT_DIR)
+NGINX_DEPENDENCIES += nginx-dav-ext
+endif
+
 # Debug logging
 NGINX_CONF_OPTS += $(if $(BR2_PACKAGE_NGINX_DEBUG),--with-debug)