yaml-cpp: bump to version 0.6.2
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 9 Jun 2018 10:46:37 +0000 (12:46 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 10 Jun 2018 12:16:35 +0000 (14:16 +0200)
- Remove boost dependency (not needed since 0.6)
- Add C++11 dependency (needed since 0.6)
- Add hash for license file

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/yaml-cpp/Config.in
package/yaml-cpp/yaml-cpp.hash
package/yaml-cpp/yaml-cpp.mk

index 6d34f4210e002e4b06b04b1a69727657e3bbc76c..e02b85df12193a4d0bd22340911e3fb5b80f1529 100644 (file)
@@ -1,14 +1,12 @@
 config BR2_PACKAGE_YAML_CPP
        bool "yaml-cpp"
        depends on BR2_INSTALL_LIBSTDCPP
-       depends on BR2_TOOLCHAIN_HAS_THREADS # boost
-       depends on BR2_USE_WCHAR # boost
-       select BR2_PACKAGE_BOOST
+       depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_7 # C++11
        help
          yaml-cpp is a YAML parser and emitter in C++ matching
          the YAML 1.2 spec.
 
          https://github.com/jbeder/yaml-cpp
 
-comment "yaml-cpp needs a toolchain w/ C++, threads, wchar"
-       depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS || !BR2_USE_WCHAR
+comment "yaml-cpp needs a toolchain w/ C++, gcc >= 4.7"
+       depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_GCC_AT_LEAST_4_7
index 7d6753732c584b8103073c80f3c7867e6b6b200d..b2c0214102b40b9902c98c759d27b9be497c699b 100644 (file)
@@ -1,2 +1,3 @@
 # locally computed
-sha256  6fb92f6f5925e0af918ffbb90acf19b7b88706ebcd40fc186b7caa76609b6350  yaml-cpp-0.5.2.tar.gz
+sha256  e4d8560e163c3d875fd5d9e5542b5fd5bec810febdcba61481fe5fc4e6b1fd05  yaml-cpp-0.6.2.tar.gz
+sha256  aa6fcc27be034e41e21dd832f9175bfe694a48491d9e14ff0fa278e19ad14f1b  LICENSE
index 6a01b02a3be1bc685036be6cf385f47a375ab265..d97c84a7cf32eec2896d733c42aa729893b31aef 100644 (file)
@@ -4,13 +4,11 @@
 #
 ################################################################################
 
-YAML_CPP_VERSION = 0.5.2
-YAML_CPP_SITE = $(call github,jbeder,yaml-cpp,release-$(YAML_CPP_VERSION))
+YAML_CPP_VERSION = 0.6.2
+YAML_CPP_SITE = $(call github,jbeder,yaml-cpp,yaml-cpp-$(YAML_CPP_VERSION))
 YAML_CPP_INSTALL_STAGING = YES
 YAML_CPP_LICENSE = MIT
-YAML_CPP_LICENSE_FILES = license.txt
-
-YAML_CPP_DEPENDENCIES = boost
+YAML_CPP_LICENSE_FILES = LICENSE
 
 # Disable testing and parse tools
 YAML_CPP_CONF_OPTS += -DYAML_CPP_BUILD_TOOLS=OFF