package/systemd: remove BR2_PACKAGE_SYSTEMD_ALL_EXTRAS
authorGabe Evans <gabe@hashrabbit.co>
Thu, 25 Feb 2016 21:55:11 +0000 (21:55 +0000)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 29 Feb 2016 21:43:19 +0000 (22:43 +0100)
The option was a bit misleading since it only selected additional
libraries without --enable/disabling any features. Including all of them
here would add a lot of bloat so instead, it is replaced with notes
detailing which features each library enables.

Signed-off-by: Gabe Evans <gabe@hashrabbit.co>
[Thomas:
 - slightly tweak Config.in help text, as suggested by Arnout.
 - add Config.in.legacy handling for BR2_PACKAGE_SYSTEMD_ALL_EXTRAS,
   as suggested by Arnout.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Config.in.legacy
package/systemd/Config.in
package/systemd/systemd.mk

index 1cd26979d72351ba5f091aebfd5adf50fde4f4c6..69b3c845d3fa5365d88ee3db4cc79bbe2fb45012 100644 (file)
@@ -145,6 +145,16 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2016.02"
 
+config BR2_PACKAGE_SYSTEMD_ALL_EXTRAS
+       bool "systemd all extras option has been removed"
+       select BR2_LEGACY
+       select BR2_PACKAGE_XZ
+       select BR2_PACKAGE_LIBGCRYPT
+       help
+         The systemd option to enable "all extras" has been
+         removed. To get the same features, the libgcrypt and xz
+         package should now be enabled.
+
 config BR2_GCC_VERSION_4_5_X
        bool "gcc 4.5.x has been removed"
        select BR2_LEGACY
index f7fc3bbfde7db6a2a8269865de0540854031c86d..b7eca3a64be8e02435cf640f82ae975922e177a4 100644 (file)
@@ -56,6 +56,9 @@ config BR2_PACKAGE_SYSTEMD
          The selection of other packages will enable some features:
 
          - acl package will add support for multi-seat.
+         - xz package will add compression support in journal and coredump.
+         - libgcrypt package will add support for journal sealing and
+           DNSSEC verification in resolved.
 
          http://freedesktop.org/wiki/Software/systemd
 
@@ -64,14 +67,6 @@ if BR2_PACKAGE_SYSTEMD
 config BR2_PACKAGE_PROVIDES_UDEV
        default "systemd"
 
-config BR2_PACKAGE_SYSTEMD_ALL_EXTRAS
-       bool "enable all extras"
-       select BR2_PACKAGE_XZ
-       select BR2_PACKAGE_LIBGCRYPT
-       help
-         Enable extra features for Systemd: journal compression and
-         signing.
-
 config BR2_PACKAGE_SYSTEMD_KDBUS
        bool "enable kdbus support"
        help
index b2cce11b094cf311476f56721c69e69b2c5b8aab..9f2dc51798a4b6aa8db00f29c8605dcec14604c6 100644 (file)
@@ -80,16 +80,20 @@ else
 SYSTEMD_CONF_OPTS += --disable-kdbus
 endif
 
-ifeq ($(BR2_PACKAGE_SYSTEMD_ALL_EXTRAS),y)
-SYSTEMD_DEPENDENCIES += xz libgcrypt
+ifeq ($(BR2_PACKAGE_XZ),y)
+SYSTEMD_DEPENDENCIES += xz
+SYSTEMD_CONF_OPTS += --enable-xz
+else
+SYSTEMD_CONF_OPTS += --disable-xz
+endif
+
+ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
+SYSTEMD_DEPENDENCIES += libgcrypt
 SYSTEMD_CONF_OPTS += \
-       --enable-xz \
        --enable-gcrypt \
        --with-libgcrypt-prefix=$(STAGING_DIR)/usr
 else
-SYSTEMD_CONF_OPTS += \
-       --disable-xz \
-       --disable-gcrypt
+SYSTEMD_CONF_OPTS += --disable-gcrypt
 endif
 
 ifeq ($(BR2_PACKAGE_SYSTEMD_JOURNAL_GATEWAY),y)