libxcb: fix build with Buildroot compiled xsltproc
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 20 Feb 2010 17:13:18 +0000 (18:13 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 20 Feb 2010 18:31:05 +0000 (19:31 +0100)
Make sure that libxcb depends on host-xsltproc, since xsltproc is
required for the compilation of libxcb.

Moreover, remove the XSLTPROC=/usr/bin/xsltproc variable definition,
which was assuming that XSLTPROC was installed on the host. xsltproc
should just be part of the PATH.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/x11r7/libxcb/libxcb.mk

index b79addd2009bd461c477dbae5ef9c5a66e35d007..19cfc6a129d232d8f99f3407d79e23752e82b9d3 100644 (file)
@@ -10,9 +10,9 @@ LIBXCB_SITE = http://xcb.freedesktop.org/dist/
 LIBXCB_INSTALL_STAGING = YES
 
 LIBXCB_AUTORECONF = NO
-LIBXCB_DEPENDENCIES = pthread-stubs xcb-proto xlib_libXdmcp xlib_libXau
+LIBXCB_DEPENDENCIES = host-libxslt pthread-stubs xcb-proto xlib_libXdmcp xlib_libXau
 LIBXCB_CONF_ENV = STAGING_DIR="$(STAGING_DIR)"
-LIBXCB_MAKE_OPT = XCBPROTO_XCBINCLUDEDIR=$(STAGING_DIR)/usr/share/xcb XSLTPROC=/usr/bin/xsltproc
+LIBXCB_MAKE_OPT = XCBPROTO_XCBINCLUDEDIR=$(STAGING_DIR)/usr/share/xcb
 
 $(eval $(call AUTOTARGETS,package/x11r7,libxcb))