libfm-extra: new package
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Fri, 21 Nov 2014 15:33:07 +0000 (15:33 +0000)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 13 Jul 2015 00:16:09 +0000 (02:16 +0200)
[Thomas:
  - adjust license: it's actually under GPLv2+, plus some bits under
    LGPLv2.1+ as noticed by Yann E. Morin, and add another license
    file for LGPLv2.1+
  - add missing dependency on host-intltool.]

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/libfm-extra/Config.in [new file with mode: 0644]
package/libfm-extra/libfm-extra.hash [new file with mode: 0644]
package/libfm-extra/libfm-extra.mk [new file with mode: 0644]

index 9787521dec32c2b48ebcef2133237b1d59817b39..1887c6b13490354f864a737f1b444af91b18de04 100644 (file)
@@ -786,6 +786,7 @@ menu "Graphics"
        source "package/libdri2/Config.in"
        source "package/libdrm/Config.in"
        source "package/libexif/Config.in"
+       source "package/libfm-extra/Config.in"
        source "package/libfreeimage/Config.in"
        source "package/libgail/Config.in"
        source "package/libgeotiff/Config.in"
diff --git a/package/libfm-extra/Config.in b/package/libfm-extra/Config.in
new file mode 100644 (file)
index 0000000..f0e0b63
--- /dev/null
@@ -0,0 +1,15 @@
+config BR2_PACKAGE_LIBFM_EXTRA
+       bool "libfm-extra"
+       select BR2_PACKAGE_LIBGLIB2
+       depends on BR2_USE_WCHAR # libglib2
+       depends on BR2_TOOLCHAIN_HAS_THREADS # libglib2
+       depends on BR2_USE_MMU # libglib2
+       help
+         The libfm-extra package contains a library and other files
+         required by menu-cache-gen libexec of menu-cache-1.0.0
+
+         http://wiki.lxde.org/en/Libfm
+
+comment "libfm-extra needs a toolchain w/ wchar, threads, C++"
+       depends on BR2_USE_MMU
+       depends on !BR2_USE_WCHAR || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/libfm-extra/libfm-extra.hash b/package/libfm-extra/libfm-extra.hash
new file mode 100644 (file)
index 0000000..5311dec
--- /dev/null
@@ -0,0 +1,2 @@
+# From http://blog.lxde.org/?p=1280
+sha1  c3f2f34086761d89d6aba549883610084ba00750  libfm-1.2.3.tar.xz
diff --git a/package/libfm-extra/libfm-extra.mk b/package/libfm-extra/libfm-extra.mk
new file mode 100644 (file)
index 0000000..f5b1928
--- /dev/null
@@ -0,0 +1,16 @@
+################################################################################
+#
+# libfm-extra
+#
+################################################################################
+
+LIBFM_EXTRA_VERSION = 1.2.3
+LIBFM_EXTRA_SOURCE = libfm-$(LIBFM_EXTRA_VERSION).tar.xz
+LIBFM_EXTRA_SITE = http://sourceforge.net/projects/pcmanfm/files
+LIBFM_EXTRA_DEPENDENCIES = libglib2 host-intltool
+LIBFM_EXTRA_LICENSE = GPLv2+, LGPLv2.1+
+LIBFM_EXTRA_LICENSE_FILES = COPYING src/extra/fm-xml-file.c
+LIBFM_EXTRA_INSTALL_STAGING = YES
+LIBFM_EXTRA_CONF_OPTS = --with-extra-only --with-gtk=no
+
+$(eval $(autotools-package))