xtables-addons: enable necessary kernel options
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 21 Oct 2014 21:10:52 +0000 (18:10 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 10 Jan 2015 17:45:23 +0000 (18:45 +0100)
Enable the required conntrack/netfilter options, otherwise
xtables-addons will fail to build.
The basic iptables options are already covered by the iptables package
which is a required dependency anyway.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
linux/linux.mk

index a3efbb2b6ce7a2daf938389d959871232c3815d9..680521c55b3813361747d5c86644482f46c36b02 100644 (file)
@@ -217,6 +217,9 @@ define LINUX_CONFIGURE_CMDS
                $(call KCONFIG_ENABLE_OPT,CONFIG_IP_NF_FILTER,$(@D)/.config)
                $(call KCONFIG_ENABLE_OPT,CONFIG_NETFILTER,$(@D)/.config)
                $(call KCONFIG_ENABLE_OPT,CONFIG_NETFILTER_XTABLES,$(@D)/.config))
+       $(if $(BR2_PACKAGE_XTABLES_ADDONS),
+               $(call KCONFIG_ENABLE_OPT,CONFIG_NF_CONNTRACK,$(@D)/.config)
+               $(call KCONFIG_ENABLE_OPT,CONFIG_NF_CONNTRACK_MARK,$(@D)/.config))
        $(if $(BR2_LINUX_KERNEL_APPENDED_DTB),
                $(call KCONFIG_ENABLE_OPT,CONFIG_ARM_APPENDED_DTB,$(@D)/.config))
        yes '' | $(TARGET_MAKE_ENV) $(MAKE1) $(LINUX_MAKE_FLAGS) -C $(@D) oldconfig