Liboil is a library of simple functions that are optimized for various
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 3 Dec 2008 09:02:46 +0000 (09:02 -0000)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 3 Dec 2008 09:02:46 +0000 (09:02 -0000)
CPUs. It is required by various GStreamer plugins.

Signed-off-by: Markus Heidelberg <markus.heidelberg@web.de>
Modifications by Thomas Petazzoni:

 - Remove the glib2 dependency, which is only necessary to build a few
   examples. If glib2 is enabled in the configuration, then we still
   depend on it in order to build the examples, but that's just
   pedantic, not so useful.

 - Remove the oil-bugreport program installed to the target by
   install-strip.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/liboil/Config.in [new file with mode: 0644]
package/liboil/liboil.mk [new file with mode: 0644]

index 2e842fb077a4db5cd678b217c767116035589e47..23d3238033c934deac07b77a81e85921038a7778 100644 (file)
@@ -78,6 +78,7 @@ source "package/libgcrypt/Config.in"
 source "package/libgpg-error/Config.in"
 source "package/libiconv/Config.in"
 source "package/liblockfile/Config.in"
+source "package/liboil/Config.in"
 source "package/libsysfs/Config.in"
 source "package/lockfile-progs/Config.in"
 source "package/logrotate/Config.in"
diff --git a/package/liboil/Config.in b/package/liboil/Config.in
new file mode 100644 (file)
index 0000000..0acbbfc
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_LIBOIL
+       bool "liboil"
+       help
+         Library of simple functions that are optimized for various CPUs.
+
+         http://liboil.freedesktop.org/
diff --git a/package/liboil/liboil.mk b/package/liboil/liboil.mk
new file mode 100644 (file)
index 0000000..6e80ed6
--- /dev/null
@@ -0,0 +1,43 @@
+#############################################################
+#
+# liboil
+#
+#############################################################
+LIBOIL_VERSION = 0.3.15
+LIBOIL_SOURCE = liboil-$(LIBOIL_VERSION).tar.gz
+LIBOIL_SITE = http://liboil.freedesktop.org/download
+LIBOIL_AUTORECONF = NO
+LIBOIL_INSTALL_STAGING = YES
+LIBOIL_INSTALL_TARGET = YES
+
+# Checking if unaligned memory access works correctly cannot be done when cross
+# compiling. For the following architectures there is no information available
+# in the configure script.
+ifeq ($(BR2_avr32),y)
+LIBOIL_CONF_ENV = as_cv_unaligned_access=no
+endif
+ifeq ($(BR2_cris),y)
+LIBOIL_CONF_ENV = as_cv_unaligned_access=yes
+endif
+ifeq ($(BR2_nios2),y)
+LIBOIL_CONF_ENV = as_cv_unaligned_access=no
+endif
+ifeq ($(BR2_s390),y)
+LIBOIL_CONF_ENV = as_cv_unaligned_access=yes
+endif
+ifeq ($(BR2_x86_64),y)
+LIBOIL_CONF_ENV = as_cv_unaligned_access=yes
+endif
+
+ifeq ($(BR2_PACKAGE_LIBGLIB2),y)
+LIBOIL_GLIB_DEP = libglib2
+endif
+
+LIBOIL_DEPENDENCIES = uclibc $(LIBOIL_GLIB_DEP)
+
+$(eval $(call AUTOTARGETS,package,liboil))
+
+$(LIBOIL_HOOK_POST_INSTALL):
+       # Remove useless bugreport program from the target
+       rm -f $(TARGET_DIR)/usr/bin/oil-bugreport
+       touch $@
\ No newline at end of file