toolchain: add a USE_MMU build option
authorMike Frysinger <vapier@gentoo.org>
Mon, 10 Jan 2011 14:28:41 +0000 (09:28 -0500)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 15 Jan 2011 13:23:36 +0000 (14:23 +0100)
Some packages need to know whether the MMU is in play, so add a toolchain
option to expose the feature to them.

[Peter: only show option on archs where it makes sense]
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/helpers.mk
toolchain/toolchain-common.in

index eb9d7421d4bcb34c8e43b01b5ded795ac977bfd1..db7c7f1c5fbb7a9d8ce489b6452c523d694c65a0 100644 (file)
@@ -146,6 +146,7 @@ check_glibc = \
        $(call check_glibc_feature,BR2_INET_IPV6,IPv6 support) ;\
        $(call check_glibc_feature,BR2_INET_RPC,RPC support) ;\
        $(call check_glibc_feature,BR2_ENABLE_LOCALE,Locale support) ;\
+       $(call check_glibc_feature,BR2_USE_MMU,MMU support) ;\
        $(call check_glibc_feature,BR2_USE_WCHAR,Wide char support) ;\
        $(call check_glibc_feature,BR2_PROGRAM_INVOCATION,Program invocation support)
 
@@ -187,6 +188,7 @@ check_uclibc = \
                exit -1; \
        fi; \
        UCLIBC_CONFIG_FILE=$${SYSROOT_DIR}/usr/include/bits/uClibc_config.h ; \
+       $(call check_uclibc_feature,__ARCH_USE_MMU__,BR2_USE_MMU,$${UCLIBC_CONFIG_FILE},MMU support) ;\
        $(call check_uclibc_feature,__UCLIBC_HAS_LFS__,BR2_LARGEFILE,$${UCLIBC_CONFIG_FILE},Large file support) ;\
        $(call check_uclibc_feature,__UCLIBC_HAS_IPV6__,BR2_INET_IPV6,$${UCLIBC_CONFIG_FILE},IPv6 support) ;\
        $(call check_uclibc_feature,__UCLIBC_HAS_RPC__,BR2_INET_RPC,$${UCLIBC_CONFIG_FILE},RPC support) ;\
index bdc6e76d6b204462ea53b274f6cbab4787b15b84..9106e1f2bdf923cebd521ff5a11584e2e44423a4 100644 (file)
@@ -66,6 +66,13 @@ config BR2_NEEDS_GETTEXT_IF_LOCALE
        bool
        default y if (BR2_NEEDS_GETTEXT && BR2_ENABLE_LOCALE)
 
+config BR2_USE_MMU
+       bool "Enable MMU support" if BR2_arm || BR2_armeb || BR2_mips || BR2_mipsel || BR2_sh || BR2_extensa
+       default y
+       help
+         If your target has a MMU, you should say Y here.  If you
+         are unsure, just say Y.
+
 config BR2_PREFER_SOFT_FLOAT
        bool
        default y if BR2_arm || BR2_armeb || BR2_avr32 || BR2_mips || BR2_mipsel