Add apr-package
authorRico Bachmann <bachmann@tofwerk.com>
Tue, 17 Apr 2012 14:35:16 +0000 (16:35 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 17 Apr 2012 14:44:19 +0000 (16:44 +0200)
Signed-off-by: Rico Bachmann <bachmann@tofwerk.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/apr/Config.in [new file with mode: 0644]
package/apr/apr.mk [new file with mode: 0644]

index 567fbedf444a04d581c6d0971cc8ad4b193a6bf3..5ae1c810dc75fbaedb6be4b6ed93ffb1851cfae5 100644 (file)
@@ -374,6 +374,7 @@ source "package/zeromq/Config.in"
 endmenu
 
 menu "Other"
+source "package/apr/Config.in"
 source "package/fftw/Config.in"
 source "package/libargtable2/Config.in"
 source "package/argp-standalone/Config.in"
diff --git a/package/apr/Config.in b/package/apr/Config.in
new file mode 100644 (file)
index 0000000..292cadb
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_APR
+       bool "apr"
+       help
+         The mission of the Apache Portable Runtime (APR) project is to create
+         and maintain software libraries that provide a predictable and
+         consistent interface to underlying platform-specific implementations
+
+         http://apr.apache.org/
diff --git a/package/apr/apr.mk b/package/apr/apr.mk
new file mode 100644 (file)
index 0000000..3158913
--- /dev/null
@@ -0,0 +1,18 @@
+#############################################################
+#
+# apr
+#
+#############################################################
+APR_VERSION = 1.4.6
+APR_SITE = http://archive.apache.org/dist/apr
+APR_INSTALL_STAGING = YES
+APR_CONF_ENV = \
+       ac_cv_file__dev_zero=yes \
+       ac_cv_func_setpgrp_void=yes \
+       apr_cv_process_shared_works=yes \
+       apr_cv_mutex_robust_shared=no \
+       apr_cv_tcp_nodelay_with_cork=yes \
+       ac_cv_sizeof_struct_iovec=8 \
+       apr_cv_mutex_recursive=yes
+
+$(eval $(call AUTOTARGETS))