gstreamer: add xorg support
authorSimon Dawson <spdawson@gmail.com>
Mon, 4 Jun 2012 20:11:42 +0000 (20:11 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 23 Jun 2012 22:49:18 +0000 (00:49 +0200)
GStreamer requires xorg support in order for the ximagesink and xvimagesink
plugins to be available.

Signed-off-by: Simon Dawson <spdawson@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/multimedia/gst-plugins-base/Config.in
package/multimedia/gst-plugins-base/gst-plugins-base.mk
package/multimedia/gst-plugins-good/gst-plugins-good.mk

index 851337b05fb5cdc639ac19b4b7e5ddc95d95649f..5d8253395a6a10e7762ff339ac3a1c62ec91be06 100644 (file)
@@ -1,6 +1,9 @@
 menuconfig BR2_PACKAGE_GST_PLUGINS_BASE
        bool "gst-plugins-base"
        depends on BR2_PACKAGE_GSTREAMER
+       select BR2_PACKAGE_XLIB_LIBX11 if BR2_PACKAGE_XORG7
+       select BR2_PACKAGE_XLIB_LIBXEXT if BR2_PACKAGE_XORG7
+       select BR2_PACKAGE_XLIB_LIBXV if BR2_PACKAGE_XORG7
        help
          A basic set of well-supported plug-ins for GStreamer.
 
index 848eaf290936e7a1851ca7551475438de7c32af5..e35a606ddbfd65b4c77429c58089187741069806 100644 (file)
@@ -17,15 +17,25 @@ GST_PLUGINS_BASE_CONF_ENV =
 
 GST_PLUGINS_BASE_CONF_OPT = \
                --disable-examples \
-               --disable-x \
-               --disable-xvideo \
-               --disable-xshm \
                --disable-oggtest \
                --disable-vorbistest \
                --disable-freetypetest
 
 GST_PLUGINS_BASE_DEPENDENCIES = gstreamer
 
+ifeq ($(BR2_PACKAGE_XORG7),y)
+GST_PLUGINS_BASE_DEPENDENCIES += xlib_libX11 xlib_libXext xlib_libXv
+GST_PLUGINS_BASE_CONF_OPT += \
+       --enable-x \
+       --enable-xshm \
+       --enable-xvideo
+else
+GST_PLUGINS_BASE_CONF_OPT += \
+       --disable-x \
+       --disable-xshm \
+       --disable-xvideo
+endif
+
 ifeq ($(BR2_PACKAGE_ORC),y)
 GST_PLUGINS_BASE_DEPENDENCIES += orc
 endif
index 4e6b73e5daf828088725a838b9d66143e4ced80f..ebd463b0e7cde733539cb23e4a9f42fd2a09d22e 100644 (file)
@@ -14,9 +14,6 @@ GST_PLUGINS_GOOD_CONF_OPT = \
                --disable-sunaudio \
                --disable-osx_audio \
                --disable-osx_video \
-               --disable-x \
-               --disable-xshm \
-               --disable-xvideo \
                --disable-aalib \
                --disable-aalibtest \
                --disable-esd \
@@ -25,6 +22,19 @@ GST_PLUGINS_GOOD_CONF_OPT = \
 
 GST_PLUGINS_GOOD_DEPENDENCIES = gstreamer gst-plugins-base
 
+ifeq ($(BR2_PACKAGE_XORG7),y)
+GST_PLUGINS_GOOD_DEPENDENCIES += xlib_libX11 xlib_libXext xlib_libXv
+GST_PLUGINS_GOOD_CONF_OPT += \
+       --enable-x \
+       --enable-xshm \
+       --enable-xvideo
+else
+GST_PLUGINS_GOOD_CONF_OPT += \
+       --disable-x \
+       --disable-xshm \
+       --disable-xvideo
+endif
+
 ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_JPEG),y)
 GST_PLUGINS_GOOD_CONF_OPT += --enable-jpeg
 GST_PLUGINS_GOOD_DEPENDENCIES += jpeg