fetchmail: gettext is not mandatory
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 19 May 2017 21:04:40 +0000 (23:04 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 31 May 2017 21:04:30 +0000 (23:04 +0200)
Even when locales are enabled, gettext is not mandatory to build
fetchmail, i.e the following defconfig builds fine:

BR2_arm=y
BR2_TOOLCHAIN_EXTERNAL=y
BR2_TOOLCHAIN_EXTERNAL_CUSTOM=y
BR2_TOOLCHAIN_EXTERNAL_DOWNLOAD=y
BR2_TOOLCHAIN_EXTERNAL_URL="http://autobuild.buildroot.org/toolchains/tarballs/br-arm-full-2017.02-1096-g54a5333.tar.bz2"
BR2_TOOLCHAIN_EXTERNAL_GCC_4_8=y
BR2_TOOLCHAIN_EXTERNAL_HEADERS_3_10=y
BR2_TOOLCHAIN_EXTERNAL_LOCALE=y
BR2_TOOLCHAIN_EXTERNAL_CXX=y
BR2_INIT_NONE=y
BR2_SYSTEM_BIN_SH_NONE=y
BR2_PACKAGE_FETCHMAIL=y

However, if gettext provides libintl, it gets used. Therefore this
commit moves gettext from a mandatory dependency to an optional
dependency.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/fetchmail/Config.in
package/fetchmail/fetchmail.mk

index 1e829a051227497d1ab8e7137b5c3a00be29c510..7c14176b236a56cad60ee49b5b284ea01307cef4 100644 (file)
@@ -4,7 +4,6 @@ config BR2_PACKAGE_FETCHMAIL
        select BR2_PACKAGE_CA_CERTIFICATES
        select BR2_PACKAGE_OPENSSL
        select BR2_PACKAGE_ZLIB
-       select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT_IF_LOCALE
        help
          Fetchmail - the mail-retrieval daemon
          Client daemon to move mail from POP and IMAP to your local computer
index 2c3786f8e7d1ef2000f6f10f2ce0d582880b5908..49ce0d3a80f4597328addfee13080ba2ab4e2600 100644 (file)
@@ -20,8 +20,12 @@ FETCHMAIL_CONF_OPTS = \
 
 FETCHMAIL_DEPENDENCIES = \
        ca-certificates \
-       openssl \
-       $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext)
+       openssl
+
+# libintl is an optional dependency
+ifeq ($(BR2_PACKAGE_GETTEXT),y)
+FETCHMAIL_DEPENDENCIES += gettext
+endif
 
 # fetchmailconf.py script is not (yet) python3-compliant.
 # Prevent the pyc-compilation with python-3 from failing by removing this