ejabberd: Replace $(HOST_DIR) to /usr in ERL path
authorJohan Oudinet <johan.oudinet@gmail.com>
Mon, 25 Sep 2017 16:34:31 +0000 (18:34 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 28 Sep 2017 21:26:33 +0000 (23:26 +0200)
Previously, it was working by luck. Buildroot has fixed its definition
of HOST_DIR and pkg-autotools.mk uses the classical /usr prefix. So,
fix this sed expression to correctly replace $(HOST_DIR) by /usr in ERL
path.

Signed-off-by: Johan Oudinet <johan.oudinet@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ejabberd/ejabberd.mk

index 9baa1124a36254718d5f90ebae7fe7df38f4ea81..35a1027efb3863dba85da5f1de047b4e90d0c490 100644 (file)
@@ -36,9 +36,9 @@ define EJABBERD_INSTALL_TARGET_CMDS
        $(TARGET_MAKE_ENV) $(MAKE) DESTDIR=$(TARGET_DIR) install -C $(@D)
 endef
 
-# Delete HOST_DIR prefix from ERL path in ejabberctl script.
+# Replace HOST_DIR prefix to /usr in ERL path of ejabberctl script.
 define EJABBERD_FIX_EJABBERDCTL
-       $(SED) 's,ERL=$(HOST_DIR),ERL=,' '$(TARGET_DIR)/usr/sbin/ejabberdctl'
+       $(SED) 's,ERL=$(HOST_DIR),ERL=/usr,' '$(TARGET_DIR)/usr/sbin/ejabberdctl'
 endef
 
 EJABBERD_POST_INSTALL_TARGET_HOOKS += EJABBERD_FIX_EJABBERDCTL