gawk: remove CC override
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 9 May 2010 14:21:52 +0000 (16:21 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 9 May 2010 21:25:07 +0000 (23:25 +0200)
For some unknown reason, gawk.mk was overriding CC to $(TARGET_CC) at
build time, while it had already been set at configure time to
"$(TARGET_CC) $(TARGET_CFLAGS)" which is already the good value.

Setting it to just $(TARGET_CC) breaks the compilation with external
toolchains because we must pass the --sysroot option. But anyway, this
was incorrect as we were loosing some CFLAGS set by Buildroot.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gawk/gawk.mk

index 8886e6b3dc2d2e76277531b26168cda178267d76..4dd1085b732233a358c44bd45f35adcc6b8c0f4b 100644 (file)
@@ -48,7 +48,7 @@ $(GAWK_DIR)/.configured: $(GAWK_DIR)/.unpacked
        touch $@
 
 $(GAWK_DIR)/$(GAWK_BINARY): $(GAWK_DIR)/.configured
-       $(MAKE) CC=$(TARGET_CC) -C $(GAWK_DIR)
+       $(MAKE) -C $(GAWK_DIR)
 
 $(TARGET_DIR)/$(GAWK_TARGET_BINARY): $(GAWK_DIR)/$(GAWK_BINARY)
        rm -f $(TARGET_DIR)/usr/bin/awk
@@ -61,7 +61,7 @@ $(TARGET_DIR)/$(GAWK_TARGET_BINARY): $(GAWK_DIR)/$(GAWK_BINARY)
 gawk: $(TARGET_DIR)/$(GAWK_TARGET_BINARY)
 
 gawk-clean:
-       $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(GAWK_DIR) uninstall
+       $(MAKE) DESTDIR=$(TARGET_DIR) -C $(GAWK_DIR) uninstall
        -$(MAKE) -C $(GAWK_DIR) clean
 
 gawk-dirclean: