pppd: install to staging
authorYegor Yefremov <yegorslists@googlemail.com>
Fri, 14 Mar 2014 10:26:32 +0000 (11:26 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 15 Mar 2014 21:39:07 +0000 (22:39 +0100)
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pppd/pppd.mk

index 0e24bd2c41b8507c5d0faf8e6486feed8ba98dbf..03118ca53ac290045d0e56761dabcfa99abd3086 100644 (file)
@@ -11,6 +11,7 @@ PPPD_LICENSE = LGPLv2+ LGPL BSD-4c BSD-3c GPLv2+
 PPPD_LICENSE_FILES = pppd/tdb.c pppd/plugins/pppoatm/COPYING \
        pppdump/bsd-comp.c pppd/ccp.c pppd/plugins/passprompt.c
 
+PPPD_INSTALL_STAGING = YES
 PPPD_TARGET_BINS = chat pppd pppdump pppstats
 PPPD_RADIUS_CONF = dictionary dictionary.ascend dictionary.compat \
                        dictionary.merit dictionary.microsoft \
@@ -92,4 +93,8 @@ define PPPD_INSTALL_TARGET_CMDS
        $(PPPD_INSTALL_RADIUS)
 endef
 
+define PPPD_INSTALL_STAGING_CMDS
+       $(MAKE) INSTROOT=$(STAGING_DIR)/ -C $(@D) $(PPPD_MAKE_OPT) install-devel
+endef
+
 $(eval $(generic-package))