keepalived: fix libnl optional dependency
authorBaruch Siach <baruch@tkos.co.il>
Mon, 20 Mar 2017 20:52:41 +0000 (22:52 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 20 Mar 2017 20:55:29 +0000 (21:55 +0100)
List libnl as a dependency when it is enabled. Make sure that
libnfnetlink is actually enabled when listing it as a dependency.

Cc: Ilias Apalodimas <apalos@gmail.com>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/keepalived/keepalived.mk

index 97a4daa8b670eb8ca24d1429ff54273d6cbdaca7..95757ff6813006e18108e286f3786958b52fe5cd 100644 (file)
@@ -13,8 +13,8 @@ KEEPALIVED_CONF_OPTS += --disable-dbus
 
 KEEPALIVED_PATCH = https://github.com/acassen/keepalived/commit/5d98b7b69fcbba84fa69e5b5e9a019bfbcb76e8b.patch
 
-ifeq ($(BR2_PACKAGE_LIBNL),y)
-KEEPALIVED_DEPENDENCIES += libnfnetlink
+ifeq ($(BR2_PACKAGE_LIBNL)$(BR2_PACKAGE_LIBNFNETLINK),yy)
+KEEPALIVED_DEPENDENCIES += libnl libnfnetlink
 endif
 
 ifeq ($(BR2_PACKAGE_IPSET),y)