toolchain: add missing stamp file touch in external toolchain
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 23 Dec 2010 09:31:08 +0000 (10:31 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 23 Dec 2010 10:13:33 +0000 (11:13 +0100)
In the support of custom external toolchains, we forgot to touch the
$(STAMP_DIR)/ext-toolchain-checked stamp file, which means that the
toolchain was re-checked and re-installed at everyt build.

At the same time, quietize a bit other stamp files touch.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/toolchain-external/ext-tool.mk

index d6153f14d16285045d0213bd9b213de41b613ee3..ab8bc947a7813b9213e815645d778c413c2514cd 100644 (file)
@@ -137,7 +137,7 @@ $(DL_DIR)/$(TOOLCHAIN_EXTERNAL_SOURCE):
 $(TOOLCHAIN_EXTERNAL_DIR)/.extracted: $(DL_DIR)/$(TOOLCHAIN_EXTERNAL_SOURCE)
        mkdir -p $(@D)
        $(INFLATE$(suffix $(TOOLCHAIN_EXTERNAL_SOURCE))) $^ | $(TAR) $(TAR_STRIP_COMPONENTS)=1 -C $(@D) $(TAR_OPTIONS) -
-       touch $@
+       $(Q)touch $@
 
 # Checks for an already installed toolchain: check the toolchain
 # location, check that it supports sysroot, and then verify that it
@@ -165,6 +165,7 @@ $(STAMP_DIR)/ext-toolchain-checked:
        else \
                $(call check_glibc,$${SYSROOT_DIR}) ; \
        fi
+       $(Q)touch $@
 
 # Integration of the toolchain into Buildroot: find the main sysroot
 # and the variant-specific sysroot, then copy the needed libraries to
@@ -194,4 +195,4 @@ $(STAMP_DIR)/ext-toolchain-installed: $(TOOLCHAIN_EXTERNAL_DEPENDENCIES)
        if [ -L $${ARCH_SYSROOT_DIR}/lib64 ] ; then \
                $(call create_lib64_symlinks) ; \
        fi ; \
-       touch $@
+       $(Q)touch $@