python-portend: new package
authorYegor Yefremov <yegorslists@googlemail.com>
Fri, 16 Jun 2017 07:27:56 +0000 (09:27 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 20 Jun 2017 19:53:53 +0000 (21:53 +0200)
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/python-portend/Config.in [new file with mode: 0644]
package/python-portend/python-portend.hash [new file with mode: 0644]
package/python-portend/python-portend.mk [new file with mode: 0644]

index 3d225ff9962ce38578cc54a3d55ea20afb784274..b852dd61fd5e054d93e024c09f658617f9cf7045 100644 (file)
@@ -783,6 +783,7 @@ menu "External python modules"
        source "package/python-pexpect/Config.in"
        source "package/python-pickleshare/Config.in"
        source "package/python-pillow/Config.in"
+       source "package/python-portend/Config.in"
        source "package/python-posix-ipc/Config.in"
        source "package/python-prompt-toolkit/Config.in"
        source "package/python-protobuf/Config.in"
diff --git a/package/python-portend/Config.in b/package/python-portend/Config.in
new file mode 100644 (file)
index 0000000..6b21078
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_PYTHON_PORTEND
+       bool "python-portend"
+       select BR2_PACKAGE_PYTHON_TEMPORA # runtime
+       help
+         TCP port monitoring utilities.
+
+         https://github.com/jaraco/portend
diff --git a/package/python-portend/python-portend.hash b/package/python-portend/python-portend.hash
new file mode 100644 (file)
index 0000000..ce4d5f6
--- /dev/null
@@ -0,0 +1,3 @@
+# md5 from https://pypi.python.org/pypi/portend/json, sha256 locally computed
+md5    a45e001d40227c4529b1a7186f4442f5  portend-1.8.tar.gz
+sha256 7de919b82c4ac60d4768fe80a2557290661aa665b7c427de6249d8cb2fde5561  portend-1.8.tar.gz
diff --git a/package/python-portend/python-portend.mk b/package/python-portend/python-portend.mk
new file mode 100644 (file)
index 0000000..b0e89b1
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-portend
+#
+################################################################################
+
+PYTHON_PORTEND_VERSION = 1.8
+PYTHON_PORTEND_SOURCE = portend-$(PYTHON_PORTEND_VERSION).tar.gz
+PYTHON_PORTEND_SITE = https://pypi.python.org/packages/3f/37/f3ab6c4a00632d53d7dfb74ba4a695e86605b92b0a94bd41fa443b60ccb6
+PYTHON_PORTEND_LICENSE = MIT
+PYTHON_PORTEND_SETUP_TYPE = setuptools
+PYTHON_PORTEND_DEPENDENCIES = host-python-setuptools-scm
+
+$(eval $(python-package))