Andrew May writes:
authorEric Andersen <andersen@codepoet.org>
Sun, 10 Oct 2004 01:12:46 +0000 (01:12 -0000)
committerEric Andersen <andersen@codepoet.org>
Sun, 10 Oct 2004 01:12:46 +0000 (01:12 -0000)
A few more little ones.

busybox fdisk with large files should be removed without large files.

gdbtarget/gdb_client got mixed up in the Makefile.in.
I think gdbtarget should have a depend on ncurses but I am not
sure if it should go in the config or in the .mk.
It may be nice to split out the server and client.

uclibc.mk was checking BR2_SOFT_FLOAT for true not y.

package/busybox/busybox.mk
toolchain/gdb/Makefile.in
toolchain/uClibc/uclibc.mk

index 34ccd6ada8f201a3b11d28837a0899290f60af1c..ef26901a559e92dcb47d4932c149ffc4f35955fe 100644 (file)
@@ -34,6 +34,7 @@ ifeq ($(BR2_LARGEFILE),y)
        $(SED) "s/^.*CONFIG_LFS.*/CONFIG_LFS=y/;" $(BUSYBOX_DIR)/.config
 else
        $(SED) "s/^.*CONFIG_LFS.*/CONFIG_LFS=n/;" $(BUSYBOX_DIR)/.config
+       $(SED) "s/^.*FDISK_SUPPORT_LARGE_DISKS.*/FDISK_SUPPORT_LARGE_DISKS=n/;" $(BUSYBOX_DIR)/.config
 endif
        $(MAKE) CC=$(TARGET_CC) CROSS="$(TARGET_CROSS)" -C $(BUSYBOX_DIR) oldconfig
        touch $(BUSYBOX_DIR)/.configured
index cdaf2ca0ef9e47c4550080692b447f020307e3eb..51a2ddb3d067af4815d475688c5a9b1be0c65251 100644 (file)
@@ -2,9 +2,9 @@ GDB_VERSION:=$(strip $(subst ",, $(BR2_GDB_VERSION)))
 #"
 
 ifeq ($(strip $(BR2_PACKAGE_GDB)),y)
-TARGETS+=gdbclient
+TARGETS+=gdb_target
 endif
 
 ifeq ($(strip $(BR2_PACKAGE_GDB_SERVER)),y)
-TARGETS+=gdbserver gdb_target
+TARGETS+=gdbserver gdbclient
 endif
index ad8cbdfcc022f7aea52ec797c9332d75ed7b44e6..1a4d515ecdefc9cb3d82f5343251f05df6c50e9d 100644 (file)
@@ -66,7 +66,7 @@ else
        $(SED) 's,^.*UCLIBC_HAS_LFS.*,UCLIBC_HAS_LFS=n,g' $(UCLIBC_DIR)/.config
 endif
        $(SED) 's,.*UCLIBC_HAS_WCHAR.*,UCLIBC_HAS_WCHAR=y,g' $(UCLIBC_DIR)/.config
-ifeq ($(BR2_SOFT_FLOAT),true)
+ifeq ($(BR2_SOFT_FLOAT),y)
        $(SED) 's,.*HAS_FPU.*,HAS_FPU=n\nUCLIBC_HAS_FLOATS=y\nUCLIBC_HAS_SOFT_FLOAT=y,g' $(UCLIBC_DIR)/.config
 endif
        mkdir -p $(TOOL_BUILD_DIR)/uClibc_dev/usr/include