package/llvm: specify LLVM_ENABLE_BINDINGS=OFF
authorJoseph Kogut <joseph.kogut@gmail.com>
Mon, 16 Mar 2020 20:01:05 +0000 (13:01 -0700)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 18 Mar 2020 21:46:22 +0000 (22:46 +0100)
LLVM builds bindings for other languages such as Go and OCaml when the
appropriate dependencies can be found. We currently don't support
building these bindings in Buildroot, as they're currently unused by any
package.

Building these bindings was originally disabled by overriding the
dependencies with values indicating that they were not found.

Newer versions of LLVM no longer disable the OCaml bindings when overriding
OCAMLFIND. Consequently, the build process attempts to install the bindings
to the default location on the host of /usr/lib/ocaml/llvm, causing a
permissions error and build failure.

Additionally, LLVM has since added the variable LLVM_ENABLE_BINDINGS to
control whether bindings are enabled, so we override that to disable the
bindings.

Signed-off-by: Joseph Kogut <joseph.kogut@gmail.com>
Reviewed-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/llvm/llvm.mk

index 28ad6a570429c771315e065e4c2a2ba902fd29b4..f1034f0365625d6f3d1280094f2da3abf8c3238f 100644 (file)
@@ -193,7 +193,8 @@ LLVM_CONF_OPTS += -DLLVM_HOST_TRIPLE=$(GNU_TARGET_NAME)
 # check preventively. Building the Go and OCaml bindings is yet unsupported.
 HOST_LLVM_CONF_OPTS += \
        -DGO_EXECUTABLE=GO_EXECUTABLE-NOTFOUND \
-       -DOCAMLFIND=OCAMLFIND-NOTFOUND
+       -DOCAMLFIND=OCAMLFIND-NOTFOUND \
+       -DLLVM_ENABLE_BINDINGS=OFF
 
 # Builds a release host tablegen that gets used during the LLVM build.
 HOST_LLVM_CONF_OPTS += -DLLVM_OPTIMIZED_TABLEGEN=ON