gdb: specify where to find lzma libraries
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Fri, 11 Mar 2016 10:16:33 +0000 (10:16 +0000)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 13 Mar 2016 22:17:08 +0000 (23:17 +0100)
As reported in...

  https://bugs.busybox.net/show_bug.cgi?id=8786

..., gdb fails to build with xz and expat support at the same time when
using an external toolchain.

This is how the problem is shown:

checking for liblzma... no
configure: error: missing liblzma for --with-lzma

And having a deeper look in gdb/config.log we can se a message like this
one:

/lib64/liblzma.so.5: undefined reference to `clock_gettime@GLIBC_2.17'

As Thomas said in the bug report quoted above, that error is related to
the fact that it find the host's lzma.

Adding --with-lzma-prefix=$(STAGING_DIR)/usr to GDB_CONF_OPTS fixes the
problem.

Credit-to: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gdb/gdb.mk

index 32d52eb3a1f49f97752d2f6c13cff6b85ebd28c7..f7d6339b7555d68b0287b1a3a389cb1cf68ae347 100644 (file)
@@ -120,6 +120,7 @@ endif
 
 ifeq ($(BR2_PACKAGE_XZ),y)
 GDB_CONF_OPTS += --with-lzma
+GDB_CONF_OPTS += --with-liblzma-prefix=$(STAGING_DIR)/usr
 GDB_DEPENDENCIES += xz
 else
 GDB_CONF_OPTS += --without-lzma