weston: add support for X11 backend
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 26 May 2016 19:44:57 +0000 (16:44 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 27 May 2016 21:05:30 +0000 (23:05 +0200)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/weston/Config.in
package/weston/weston.mk

index 8cefa411b4217f009fcce01ed44020065130ea6e..44f954abe06b045bca7b8ae41799d0514a3a8f47 100644 (file)
@@ -82,4 +82,14 @@ config BR2_PACKAGE_WESTON_RPI
        depends on BR2_PACKAGE_RPI_USERLAND
        select BR2_PACKAGE_WESTON_HAS_COMPOSITOR
 
+config BR2_PACKAGE_WESTON_X11
+       bool "X11 compositor"
+       depends on BR2_PACKAGE_XORG7
+       select BR2_PACKAGE_LIBXCB
+       select BR2_PACKAGE_XLIB_LIBX11
+       select BR2_PACKAGE_WESTON_HAS_COMPOSITOR
+
+comment "X11 compositor needs X.org enabled"
+       depends on !BR2_PACKAGE_XORG7
+
 endif
index 63c43a3231888b463c5309b487242d15a7732d95..3a0189f1ae4f29565e3410e3d39ff763f00e7dcf 100644 (file)
@@ -19,7 +19,6 @@ WESTON_DEPENDENCIES = host-pkgconf wayland wayland-protocols \
 WESTON_CONF_OPTS = \
        --with-dtddir=$(STAGING_DIR)/usr/share/wayland \
        --disable-xwayland \
-       --disable-x11-compositor \
        --disable-wayland-compositor \
        --disable-headless-compositor \
        --disable-colord \
@@ -103,6 +102,15 @@ else
 WESTON_CONF_OPTS += --disable-rpi-compositor
 endif # BR2_PACKAGE_WESTON_RPI
 
+ifeq ($(BR2_PACKAGE_WESTON_X11),y)
+WESTON_CONF_OPTS += \
+       --enable-x11-compositor \
+       WESTON_NATIVE_BACKEND=x11-backend.so
+WESTON_DEPENDENCIES += libxcb xlib_libX11
+else
+WESTON_CONF_OPTS += --disable-x11-compositor
+endif
+
 ifeq ($(BR2_PACKAGE_LIBVA),y)
 WESTON_CONF_OPTS += --enable-vaapi-recorder
 WESTON_DEPENDENIES += libva