lzop: new package
authorPeter Korsgaard <jacmet@sunsite.dk>
Thu, 9 Apr 2009 09:46:54 +0000 (09:46 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 9 Apr 2009 09:46:54 +0000 (09:46 -0000)
Patch by Olaf Rempel <razzor@kopf-tisch.de>, closes #245.

lzop is a file compressor which is very similar to gzip.
lzop uses the LZO data compression library for compression services.
http://www.lzop.org/

package/Config.in
package/lzop/Config.in [new file with mode: 0644]
package/lzop/lzop.mk [new file with mode: 0644]

index 26f9965e98f73d95f3040f6b7225a3b4b0e646d2..004894bcd57257c67c265c33b7389d70c2550752 100644 (file)
@@ -404,6 +404,7 @@ if !BR2_PACKAGE_BUSYBOX_HIDE_OTHERS
 source "package/gzip/Config.in"
 endif
 source "package/lzo/Config.in"
+source "package/lzop/Config.in"
 source "package/lzma/Config.in"
 source "package/zlib/Config.in"
 endmenu
diff --git a/package/lzop/Config.in b/package/lzop/Config.in
new file mode 100644 (file)
index 0000000..c911823
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_LZOP
+       bool "lzop"
+       select BR2_PACKAGE_LZO
+       help
+         lzop is a file compressor which is very similar to gzip.
+         lzop uses the LZO data compression library for compression services.
+
+         http://www.lzop.org/
diff --git a/package/lzop/lzop.mk b/package/lzop/lzop.mk
new file mode 100644 (file)
index 0000000..796686a
--- /dev/null
@@ -0,0 +1,12 @@
+#############################################################
+#
+# lzop
+#
+#############################################################
+LZOP_VERSION:=1.02rc1
+LZOP_SOURCE:=lzop-$(LZOP_VERSION).tar.gz
+LZOP_SITE:=http://www.lzop.org/download/
+LZOP_CONF_OPT:=--program-prefix=""
+LZOP_DEPENDENCIES:=lzo
+
+$(eval $(call AUTOTARGETS,package,lzop))