grub/grub2: drop unnecessary dependency on uclibc
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 15 Mar 2010 22:28:40 +0000 (23:28 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 12 Jun 2010 11:38:43 +0000 (13:38 +0200)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
boot/grub/grub.mk
boot/grub2/grub2.mk

index 96b082dcf10575ccacc628daa975ddf64090a5ef..74ea77fb0a442dc475d96b8c0c3c20fb93ff2a52 100644 (file)
@@ -96,7 +96,7 @@ ifeq ($(BR2_TARGET_GRUB_SPLASH),y)
 endif
        touch $@
 
-grub: uclibc $(GRUB_DIR)/.installed
+grub: $(GRUB_DIR)/.installed
 
 grub-clean:
        $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(GRUB_DIR) uninstall
index a298ae689523838180b3fad158e3fd663b2da749..06e15240ad961b249828c40b5310e9bbf22854f3 100644 (file)
@@ -93,7 +93,7 @@ ifeq ($(BR2_TARGET_GRUB2_SPLASH),y)
 endif
        touch $@
 
-grub2: uclibc $(GRUB2_DIR)/.installed
+grub2: $(GRUB2_DIR)/.installed
 
 grub2-clean:
        $(MAKE) DESTDIR=$(TARGET_DIR) CC=$(TARGET_CC) -C $(GRUB2_DIR) uninstall