luafilesystem: remove LARGE_FILE constraint
authorFrancois Perrad <francois.perrad@gadz.org>
Thu, 5 Aug 2010 14:36:34 +0000 (16:36 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 24 Aug 2010 13:05:19 +0000 (15:05 +0200)
Add a patch to luafilesystem so that it builds correctly when large
files are not supported. This allows to remove the dependency of
luafilesystem on large file support on the toolchain. Packages such as
cgilua, wsapi and xavante, which depend on luafilesystem, also get
their dependency on large file support removed.

Fixes bug #2359.

Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
package/cgilua/Config.in
package/luafilesystem/Config.in
package/luafilesystem/luafilesystem-without_large_file.patch [new file with mode: 0644]
package/luafilesystem/luafilesystem.mk
package/wsapi/Config.in
package/xavante/Config.in

index a74e49f53698eb400b64884eb00d22cb228b1f4b..b43ba97d15f6eda69a06cda5f9b73906fe32c2fc 100644 (file)
@@ -1,6 +1,5 @@
 config BR2_PACKAGE_CGILUA
        bool "cgilua"
-       depends on BR2_LARGEFILE
        select BR2_PACKAGE_LUA_SHARED_LIBRARY
        select BR2_PACKAGE_LUAFILESYSTEM
        help
@@ -8,6 +7,3 @@ config BR2_PACKAGE_CGILUA
          and manipulating input data from Web forms.
 
          http://luaforge.net/projects/cgilua/
-
-comment "cgilua requires a toolchain with LARGEFILE support"
-       depends on !BR2_LARGEFILE
index 6cb6c24757a8e2a7da001436c14042318264d5e0..edcb414a9aefc9c92eba93bd3d9a976ff931c201 100644 (file)
@@ -1,12 +1,8 @@
 config BR2_PACKAGE_LUAFILESYSTEM
        bool "luafilesystem"
-       depends on BR2_LARGEFILE
        select BR2_PACKAGE_LUA_SHARED_LIBRARY
        help
          LuaFileSystem offers a portable way to access
          the underlying directory structure and file attributes.
 
-         http://luaforge.net/projects/luafilesystem/
-
-comment "luafilesystem requires a toolchain with LARGEFILE support"
-       depends on !BR2_LARGEFILE
+         http://keplerproject.github.com/luafilesystem/
diff --git a/package/luafilesystem/luafilesystem-without_large_file.patch b/package/luafilesystem/luafilesystem-without_large_file.patch
new file mode 100644 (file)
index 0000000..b1f41c0
--- /dev/null
@@ -0,0 +1,20 @@
+diff --git a/src/lfs.c b/src/lfs.c
+index 85f01e3..ed49f50 100644
+--- a/src/lfs.c
++++ b/src/lfs.c
+@@ -22,13 +22,13 @@
+ #ifndef _WIN32
+ #ifndef _AIX
+-#define _FILE_OFFSET_BITS 64 /* Linux, Solaris and HP-UX */
++//#define _FILE_OFFSET_BITS 64 /* Linux, Solaris and HP-UX */
+ #else
+ #define _LARGE_FILES 1 /* AIX */
+ #endif
+ #endif
+-#define _LARGEFILE64_SOURCE
++//#define _LARGEFILE64_SOURCE
+ #include <errno.h>
+ #include <stdio.h>
index a27080cd6ca2a5c0e3802e6b0f5a649d617024a9..e6887341425c11ee2b0970b412d42389fc83760c 100644 (file)
@@ -8,8 +8,12 @@ LUAFILESYSTEM_VERSION = 1.5.0
 LUAFILESYSTEM_SITE = http://github.com/downloads/keplerproject/luafilesystem
 LUAFILESYSTEM_DEPENDENCIES = lua
 
+ifeq ($(BR2_LARGEFILE),y)
+LFS_CFLAGS = -D_FILE_OFFSET_BITS=64 _LARGEFILE64_SOURCE
+endif
+
 define LUAFILESYSTEM_BUILD_CMDS
-       $(MAKE) -C $(@D) CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS) -fPIC"
+       $(MAKE) -C $(@D) CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS) $(LFS_CFLAGS) -fPIC"
 endef
 
 define LUAFILESYSTEM_INSTALL_TARGET_CMDS
index 472bbfcee1ddcce876f25a562e1857805ddc9194..36216484849d7909e871c3474f1219f3708d50ce 100644 (file)
@@ -1,6 +1,5 @@
 config BR2_PACKAGE_WSAPI
        bool "wsapi"
-       depends on BR2_LARGEFILE # luafilesystem
        select BR2_PACKAGE_COXPCALL
        select BR2_PACKAGE_LUAFILESYSTEM
        select BR2_PACKAGE_RINGS
@@ -8,6 +7,3 @@ config BR2_PACKAGE_WSAPI
          API that abstracts the web server from Lua web applications.
 
          http://keplerproject.github.com/wsapi/
-
-comment "wsapi requires a toolchain with LARGEFILE support"
-       depends on !BR2_LARGEFILE
index a1b47c33b154c9343352e68bf8ebab5d0e1e0f1c..a7df53021724b237f82af45a1af677c5e2f535a5 100644 (file)
@@ -1,6 +1,5 @@
 config BR2_PACKAGE_XAVANTE
        bool "xavante"
-       depends on BR2_LARGEFILE # luafilesystem
        select BR2_PACKAGE_LUA_SHARED_LIBRARY
        select BR2_PACKAGE_CGILUA
        select BR2_PACKAGE_COPAS
@@ -13,6 +12,3 @@ config BR2_PACKAGE_XAVANTE
          architecture based on URI mapped handlers.
 
          http://keplerproject.github.com/xavante/
-
-comment "xavante requires a toolchain with LARGEFILE support"
-       depends on !BR2_LARGEFILE