package/matchbox-panel: fix WiFi monitoring
authorYann E. MORIN <yann.morin.1998@free.fr>
Wed, 3 Jun 2015 20:41:49 +0000 (22:41 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 9 Jun 2015 21:10:40 +0000 (23:10 +0200)
matchbox-panel can build a simple applet to monitor the WiFi. For that,
it tries to see if libiwl is available; if so, WiFi monitoring is
enabled, otherwise it is disabled; there is not option to explicitly
enable or disable it.

Currently, matchbox-panel depends on the wireless-tools package.
However, that's not enough, since the library will only be installed if
explicitly enabled in the menuconfig *and* this is not a static build.

Change the dependency to be on the library, not the package.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/matchbox-panel/matchbox-panel.mk

index e71337cd8ba9b6240430fc606fd75955a12a6b7e..aa2d4179222d2ef6d0b4bdc058175f657e2a309c 100644 (file)
@@ -27,7 +27,7 @@ else
 MATCHBOX_PANEL_CONF_OPTS += --disable-acpi-linux
 endif
 
-ifeq ($(BR2_PACKAGE_WIRELESS_TOOLS),y)
+ifeq ($(BR2_PACKAGE_WIRELESS_TOOLS_LIB),y)
 MATCHBOX_PANEL_DEPENDENCIES += wireless_tools
 endif