package/tiff: Rework tiff utilities handling
authorBernd Kuhls <bernd.kuhls@t-online.de>
Thu, 23 Apr 2015 21:18:16 +0000 (23:18 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 25 Apr 2015 08:15:10 +0000 (10:15 +0200)
Remove all utility-specific options in favour of a generic
option which select either all or no packages. If users
want something more fine-grained than that, they can always
remove the unnecessary tools in a post-build script.

Since tiff has no configure option or Makefile target to prevent
the build/install of its utilities specific Makefile targets are
called to build the libtiff and, optionally, the utilities.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
[Arnout: more compact implementation, slightly extend help text]
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Config.in.legacy
package/tiff/Config.in
package/tiff/tiff.mk

index 70a90433f0b62e912122e91cb303319cd39e180e..90f474cf0f9a0a81dbeafda9554c05d50feb0d5d 100644 (file)
@@ -107,6 +107,22 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2015.05"
 
+config BR2_PACKAGE_TIFF_TIFF2PDF
+       bool "tiff utility-specific option removed"
+       select BR2_LEGACY
+       select BR2_PACKAGE_TIFF_UTILITIES
+       help
+         utility-specific options have been removed in favour of
+         the new option BR2_PACKAGE_TIFF_UTILITIES.
+
+config BR2_PACKAGE_TIFF_TIFFCP
+       bool "tiff utility-specific option removed"
+       select BR2_LEGACY
+       select BR2_PACKAGE_TIFF_UTILITIES
+       help
+         utility-specific options have been removed in favour of
+         the new option BR2_PACKAGE_TIFF_UTILITIES.
+
 config BR2_LINUX_KERNEL_EXT_RTAI_PATCH
        bool "RTAI patch file path has been removed"
        help
index 3a929f7a34bdbabd88720c120c5df06432f17ad0..acb335cc9d07efd406412ef9fca2f553bed4c432 100644 (file)
@@ -60,14 +60,9 @@ config BR2_PACKAGE_TIFF_JBIG
        default y
 endmenu
 
-config BR2_PACKAGE_TIFF_TIFF2PDF
-       bool "tiff2pdf"
+config BR2_PACKAGE_TIFF_UTILITIES
+       bool "tiff utilities"
        help
-         tiff2pdf utility
-
-config BR2_PACKAGE_TIFF_TIFFCP
-       bool "tiffcp"
-       help
-         tiffcp utility
+         Install all tiff utilities.
 
 endif
index 06f0e347d2c7a2053297f9482af7304aea009005..6db2abdc883dd49c8622b75266c8ea767cc30008 100644 (file)
@@ -15,36 +15,6 @@ TIFF_CONF_OPTS = \
 
 TIFF_DEPENDENCIES = host-pkgconf
 
-TIFF_TOOLS_TO_DELETE = \
-       bmp2tiff \
-       fax2ps \
-       fax2tiff \
-       gif2tiff \
-       pal2rgb \
-       ppm2tiff \
-       ras2tiff \
-       raw2tiff \
-       rgb2ycbcr \
-       thumbnail \
-       tiff2bw \
-       tiff2ps \
-       tiff2rgba \
-       tiffcmp \
-       tiffcrop \
-       tiffdither \
-       tiffdump \
-       tiffinfo \
-       tiffmedian \
-       tiffset \
-       tiffsplit \
-
-ifeq ($(BR2_PACKAGE_TIFF_TIFF2PDF),)
-TIFF_TOOLS_TO_DELETE += tiff2pdf
-endif
-ifeq ($(BR2_PACKAGE_TIFF_TIFFCP),)
-TIFF_TOOLS_TO_DELETE += tiffcp
-endif
-
 ifneq ($(BR2_PACKAGE_TIFF_CCITT),y)
 TIFF_CONF_OPTS += --disable-ccitt
 endif
@@ -97,10 +67,11 @@ ifneq ($(BR2_PACKAGE_TIFF_JBIG),y)
 TIFF_CONF_OPTS += --disable-jbig
 endif
 
-define TIFF_REMOVE_TOOLS_FIXUP
-       rm -f $(addprefix $(TARGET_DIR)/usr/bin/,$(TIFF_TOOLS_TO_DELETE))
-endef
+TIFF_SUBDIRS = port libtiff
+ifeq ($(BR2_PACKAGE_TIFF_UTILITIES),y)
+TIFF_SUBDIRS += tools
+endif
 
-TIFF_POST_INSTALL_TARGET_HOOKS += TIFF_REMOVE_TOOLS_FIXUP
+TIFF_MAKE = $(MAKE) SUBDIRS="$(TIFF_SUBDIRS)"
 
 $(eval $(autotools-package))