package/multimedia: apply libtool patch where possible
authorPeter Korsgaard <jacmet@sunsite.dk>
Thu, 17 Feb 2011 12:52:47 +0000 (13:52 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 17 Feb 2011 12:52:47 +0000 (13:52 +0100)
Now that we have libtool-2.2.x patch support, we can get rid of a bunch
of _LIBTOOL_PATH = NO, fixing (potential) cross link issues.

Notice: libmad/libid3tag/madplay/taglib not changed, as they use a very
old 1.5 version, where our buildroot-libtool-v1.5.patch doesn't apply.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/multimedia/gst-ffmpeg/gst-ffmpeg.mk
package/multimedia/gst-plugins-bad/gst-plugins-bad.mk
package/multimedia/gst-plugins-base/gst-plugins-base.mk
package/multimedia/gst-plugins-good/gst-plugins-good.mk
package/multimedia/gst-plugins-ugly/gst-plugins-ugly.mk
package/multimedia/gstreamer/gstreamer.mk
package/multimedia/libmms/libmms.mk
package/multimedia/swfdec/swfdec.mk

index d424aa3f1fdecc97e5969523372891ac70ee182d..6e91ad5970109065470c71389e4a9d4551298374 100644 (file)
@@ -7,7 +7,6 @@ GST_FFMPEG_VERSION = 0.10.9
 GST_FFMPEG_SOURCE = gst-ffmpeg-$(GST_FFMPEG_VERSION).tar.bz2
 GST_FFMPEG_SITE = http://gstreamer.freedesktop.org/src/gst-ffmpeg
 GST_FFMPEG_INSTALL_STAGING = YES
-GST_FFMPEG_LIBTOOL_PATCH = NO
 GST_FFMPEG_DEPENDENCIES = gstreamer gst-plugins-base ffmpeg liboil
 GST_FFMPEG_CONF_OPT = --with-system-ffmpeg
 
index c3002562d455bcbeb5934443511875404ba5b5d8..357acf3b35422e66fd4f542d0ac0cfba143c5e7a 100644 (file)
@@ -6,7 +6,6 @@
 GST_PLUGINS_BAD_VERSION = 0.10.21
 GST_PLUGINS_BAD_SOURCE = gst-plugins-bad-$(GST_PLUGINS_BAD_VERSION).tar.bz2
 GST_PLUGINS_BAD_SITE = http://gstreamer.freedesktop.org/src/gst-plugins-bad
-GST_PLUGINS_BAD_LIBTOOL_PATCH = NO
 
 GST_PLUGINS_BAD_CONF_OPT = \
                --disable-examples
index 828d156c026adb986fe92087dbef33f1b4d42278..1d0b19dd614dff34034b21e586653a3aa7b5b504 100644 (file)
@@ -7,7 +7,6 @@ GST_PLUGINS_BASE_VERSION = 0.10.32
 GST_PLUGINS_BASE_SOURCE = gst-plugins-base-$(GST_PLUGINS_BASE_VERSION).tar.bz2
 GST_PLUGINS_BASE_SITE = http://gstreamer.freedesktop.org/src/gst-plugins-base
 GST_PLUGINS_BASE_INSTALL_STAGING = YES
-GST_PLUGINS_BASE_LIBTOOL_PATCH = NO
 
 # freetype is only used by examples, but if it is not found
 # and the host has a freetype-config script, then the host
index 7a67dc5cf449263e8cd0c97b2672e987dd2b279a..10044e7d8a7bd7d63e9388c9a09c075a78009cf3 100644 (file)
@@ -6,7 +6,6 @@
 GST_PLUGINS_GOOD_VERSION = 0.10.27
 GST_PLUGINS_GOOD_SOURCE = gst-plugins-good-$(GST_PLUGINS_GOOD_VERSION).tar.bz2
 GST_PLUGINS_GOOD_SITE = http://gstreamer.freedesktop.org/src/gst-plugins-good
-GST_PLUGINS_GOOD_LIBTOOL_PATCH = NO
 
 GST_PLUGINS_GOOD_CONF_OPT = \
                --disable-debug \
index 4eb02e5094e27be71d35861866fefc8eb667a202..a173df19430fb3e1ddf8621ee6adc0d4dc1ecfbe 100644 (file)
@@ -6,7 +6,6 @@
 GST_PLUGINS_UGLY_VERSION = 0.10.17
 GST_PLUGINS_UGLY_SOURCE = gst-plugins-ugly-$(GST_PLUGINS_UGLY_VERSION).tar.bz2
 GST_PLUGINS_UGLY_SITE = http://gstreamer.freedesktop.org/src/gst-plugins-ugly
-GST_PLUGINS_UGLY_LIBTOOL_PATCH = NO
 
 GST_PLUGINS_UGLY_CONF_OPT = \
                --disable-examples
index 558d4764010ada58fad25ad5e77439850bbf3bdd..db5ccaf6509d00598a2ea6f49ffee3fe6cf69d9e 100644 (file)
@@ -7,7 +7,6 @@ GSTREAMER_VERSION = 0.10.32
 GSTREAMER_SOURCE = gstreamer-$(GSTREAMER_VERSION).tar.bz2
 GSTREAMER_SITE = http://gstreamer.freedesktop.org/src/gstreamer
 GSTREAMER_INSTALL_STAGING = YES
-GSTREAMER_LIBTOOL_PATCH = NO
 
 # Checking if unaligned memory access works correctly cannot be done when cross
 # compiling. For the following architectures there is no information available
index a8f4527fd578cc08be04a9ee43dfdfe1e22d477e..d11f0bead3f66a48b84bb561d7f88268a84452c1 100644 (file)
@@ -8,7 +8,6 @@ LIBMMS_SOURCE = libmms-$(LIBMMS_VERSION).tar.gz
 LIBMMS_SITE = http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/libmms
 
 LIBMMS_AUTORECONF = NO
-LIBMMS_LIBTOOL_PATCH = NO
 LIBMMS_INSTALL_STAGING = YES
 LIBMMS_INSTALL_TARGET = YES
 
index 58bfd1576d064ae58e154335af094813cede1c19..9b4b72953c111a901091021711aa14a49b820773 100644 (file)
@@ -12,7 +12,6 @@ SWFDEC_MAKE_OPT = \
        GLIB_MKENUMS=$(HOST_DIR)/usr/bin/glib-mkenums \
        GLIB_GENMARSHAL=$(HOST_DIR)/usr/bin/glib-genmarshal
 
-SWFDEC_LIBTOOL_PATCH = NO
 SWFDEC_INSTALL_STAGING = YES
 SWFDEC_INSTALL_TARGET = YES