libdrm: Add menu option to install the test programs
authorEzequiel García <ezequiel@vanguardiasur.com.ar>
Fri, 23 May 2014 15:13:19 +0000 (12:13 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 14 Jun 2014 17:05:38 +0000 (19:05 +0200)
The libdrm has a bunch of useful test programs. Add an option to pass
the configure option to install them.

Signed-off-by: Ezequiel Garcia <ezequiel@vanguardiasur.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libdrm/Config.in
package/libdrm/libdrm.mk

index e6a7a4258df98cb11b56f6ef6ea15de4ef574fdd..9acc9085922e145550c9219419f0c153d40a50e8 100644 (file)
@@ -10,6 +10,11 @@ config BR2_PACKAGE_LIBDRM
 
 if BR2_PACKAGE_LIBDRM
 
+config BR2_PACKAGE_LIBDRM_INSTALL_TESTS
+       bool "Install test programs"
+       help
+         This option allows to install the libdrm test programs.
+
 menu "DRM Drivers"
 
 config BR2_PACKAGE_LIBDRM_INTEL
index b3e4d7ae8f785f1d9079181c6f9b0023320873a0..d912d6dddbdd10352312e146e58b467c052f158d 100644 (file)
@@ -69,4 +69,8 @@ else
 LIBDRM_CONF_OPT += --disable-udev
 endif
 
+ifeq ($(BR2_PACKAGE_LIBDRM_INSTALL_TESTS),y)
+LIBDRM_CONF_OPT += --enable-install-test-programs
+endif
+
 $(eval $(autotools-package))