zlib-ng: new package
authorStefan Fröberg <stefan.froberg@petroprogram.com>
Wed, 29 Nov 2017 21:17:14 +0000 (23:17 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 3 Jan 2018 21:42:52 +0000 (22:42 +0100)
zlib-ng, a fast Zlib replacement

Signed-off-by: Stefan Fröberg <stefan.froberg@petroprogram.com>
[Thomas: drop host variant.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
DEVELOPERS
package/zlib-ng/zlib-ng.hash [new file with mode: 0644]
package/zlib-ng/zlib-ng.mk [new file with mode: 0644]
package/zlib/Config.in

index 458b4521bf7aff8df6d96ab3b0e2adb56ac90bcd..a9a9ac5a394435d04638c2d30fd0a945dcd54e01 100644 (file)
@@ -1638,6 +1638,7 @@ F:        package/elfutils/
 F:     package/libtasn1/
 F:     package/proxychains-ng/
 F:     package/yasm/
+F:     package/zlib-ng/
 
 N:     Stefan Sørensen <stefan.sorensen@spectralink.com>
 F:     package/cracklib/
diff --git a/package/zlib-ng/zlib-ng.hash b/package/zlib-ng/zlib-ng.hash
new file mode 100644 (file)
index 0000000..2e89a8d
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally calculated
+sha256 2ec78c8c13530bffaebfc10be2f4695c47cf50fe2fbc2104606467703836fa0e zlib-ng-a17fefa147942edbf80ab22a16bcbc2419def12d.tar.gz
+sha256 d3c80be055d94d798eaa786116e84fa0b010bc11420b5d2060d978ea77845436 LICENSE.md
diff --git a/package/zlib-ng/zlib-ng.mk b/package/zlib-ng/zlib-ng.mk
new file mode 100644 (file)
index 0000000..3d9651c
--- /dev/null
@@ -0,0 +1,22 @@
+################################################################################
+#
+# zlib-ng
+#
+################################################################################
+
+ZLIB_NG_VERSION = a17fefa147942edbf80ab22a16bcbc2419def12d
+ZLIB_NG_SITE = $(call github,mtl1979,zlib-ng,$(ZLIB_NG_VERSION))
+ZLIB_NG_LICENSE = Zlib
+ZLIB_NG_LICENSE_FILES = LICENSE.md
+ZLIB_NG_INSTALL_STAGING = YES
+ZLIB_NG_PROVIDES = zlib
+
+# Build with zlib compatible API, gzFile support and optimizations on
+ZLIB_NG_CONF_OPTS += -DZLIB_COMPAT=1 -DWITH_GZFILEOP=1 -DWITH_OPTIM=1 -DCC=$(TARGET_CC)
+
+# Enable NEON and ACLE on ARM
+ifeq ($(BR2_arm),y)
+ZLIB_NG_CONF_OPTS += -DWITH_ACLE=1 -DWITH_NEON=1
+endif
+
+$(eval $(cmake-package))
index bdc1da60561d6d47ba24d359b0f255f70a49fc93..87abc2bdd5fe4937ab9fa186b2e758360c1168e9 100644 (file)
@@ -20,6 +20,15 @@ config BR2_PACKAGE_LIBZLIB
 
          http://www.zlib.net
 
+config BR2_PACKAGE_ZLIB_NG
+       bool "zlib-ng"
+       select BR2_PACKAGE_HAS_ZLIB
+       help
+         Zlib replacement with optimizations for
+         "next generation" systems.
+
+         https://github.com/mtl1979/zlib-ng/tree/renamelib
+
 endchoice
 
 config BR2_PACKAGE_HAS_ZLIB
@@ -28,6 +37,7 @@ config BR2_PACKAGE_HAS_ZLIB
 config BR2_PACKAGE_PROVIDES_ZLIB
        string
        default "libzlib" if BR2_PACKAGE_LIBZLIB
+       default "zlib-ng" if BR2_PACKAGE_ZLIB_NG
 
 endif