gnutls: needs argp-standalone for musl/uclibc
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 4 Dec 2015 17:01:39 +0000 (14:01 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 4 Dec 2015 20:38:03 +0000 (21:38 +0100)
It's required for crywrap (tools), fixes:
http://autobuild.buildroot.net/results/2d9/2d98fced7ff7c3b5c39a97eb1c8db7dd651fa86c/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gnutls/Config.in
package/gnutls/gnutls.mk

index dde23cec7abba0d2bdd6456f814dc5481ad7ebd1..998e213c7d0f8e34cb6f4af7e862c13dd4f7b7d2 100644 (file)
@@ -14,6 +14,8 @@ if BR2_PACKAGE_GNUTLS
 
 config BR2_PACKAGE_GNUTLS_TOOLS
        bool "install tools"
+       select BR2_PACKAGE_ARGP_STANDALONE \
+               if BR2_TOOLCHAIN_USES_UCLIBC || BR2_TOOLCHAIN_USES_MUSL
        help
          Install GnuTLS command line tools for various cryptographic tasks.
 
index 3b9fc7fca706b970ad232f954ad8a4b288d8c58f..a7342d604c48e4863113e1a1b382263ba57a4003 100644 (file)
@@ -44,6 +44,12 @@ ifeq ($(BR2_PACKAGE_GNUTLS_TOOLS),)
 GNUTLS_CONF_OPTS += --disable-crywrap
 endif
 
+# Prerequisite for crywrap
+ifeq ($(BR2_PACKAGE_ARGP_STANDALONE),y)
+GNUTLS_CONF_ENV += LIBS="-largp"
+GNUTLS_DEPENDENCIES += argp-standalone
+endif
+
 # libidn support for nommu must exclude the crywrap wrapper (uses fork)
 GNUTLS_CONF_OPTS += $(if $(BR2_USE_MMU),,--disable-crywrap)