rtai: remove option BR2_LINUX_KERNEL_EXT_RTAI_PATCH
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 21 Apr 2015 21:36:28 +0000 (23:36 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 22 Apr 2015 20:12:15 +0000 (22:12 +0200)
This commit removes BR2_LINUX_KERNEL_EXT_RTAI_PATCH because this
option never worked. It was added in commit
8797a9cd1fe6723db34b0c125d0d9d04e3483e8d, which added package/rtai/
and RTAI as a Linux extension.

The option prompt says "Path for RTAI patch file", so let's say you
specify /home/foo/bar/myrtai.patch as the value for
BR2_LINUX_KERNEL_EXT_RTAI_PATCH.

Then the code does:

RTAI_PATCH = $(call qstrip,$(BR2_LINUX_KERNEL_EXT_RTAI_PATCH))

and we have a package called 'rtai', so the normal logic of
<pkg>_PATCH applies. Since the <pkg>_PATCH value does not contain
ftp://, http:// or https://, the package infrastructure will try to
download $(RTAI_SITE)/$(RTAI_PATCH), i.e:

   https://www.rtai.org/userfiles/downloads/RTAI/home/foo/bar/myrtai.patch

Pretty clear that it has no chance of working.

Now, let's assume an URL is used as the value of
BR2_LINUX_KERNEL_EXT_RTAI_PATCH, such as
http://foo.com/bar/myrtai.patch. In this case, it will be properly
downloaded by the package infrastructure. But then, the following code
kicks in:

define RTAI_PREPARE_KERNEL
       $(APPLY_PATCHES)                        \
               $(LINUX_DIR)                    \
               $(dir $(RTAI_PATCH))            \
               $(notdir $(RTAI_PATCH))
endef

The value of $(dir $(RTAI_PATCH)) will be http://foo.com/bar/. How
can $(APPLY_PATCHES) make use of such a stupid patch location?

[Thomas: add Config.in.legacy handling, as suggested by Arnout, even
if we believe that no-one could have ever used this option.]

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Config.in.legacy
linux/Config.ext.in
linux/linux-ext-rtai.mk

index 97bc939802245e1b4b7c4bc81db8490ea83aa13a..70a90433f0b62e912122e91cb303319cd39e180e 100644 (file)
@@ -107,6 +107,11 @@ endif
 ###############################################################################
 comment "Legacy options removed in 2015.05"
 
+config BR2_LINUX_KERNEL_EXT_RTAI_PATCH
+       bool "RTAI patch file path has been removed"
+       help
+         This option has never worked, so it has been removed.
+
 config BR2_TARGET_GENERIC_PASSWD_DES
        bool "Encoding passwords with DES has been removed"
        select BR2_LEGACY
index c909254cdd6140bdb029b71272cc14ed0c8e0fb7..ea79aa166cc1c20c5495a7137d85867e8f9adba5 100644 (file)
@@ -44,12 +44,6 @@ config BR2_LINUX_KERNEL_EXT_RTAI
        help
          RTAI Kernel part.
 
-config BR2_LINUX_KERNEL_EXT_RTAI_PATCH
-       depends on BR2_LINUX_KERNEL_EXT_RTAI
-       string "Path for RTAI patch file"
-       help
-         Optionally, explicitly specify the RTAI patch to use.
-
 # fbtft
 config BR2_LINUX_KERNEL_EXT_FBTFT
        bool "FB TFT drivers"
index 07e7a19cd9e7a34911a638d9f18bcb3f874539df..0cc1232b965dfc5a51258113f6feb17458dd4832 100644 (file)
@@ -6,8 +6,6 @@
 
 LINUX_EXTENSIONS += rtai
 
-RTAI_PATCH = $(call qstrip,$(BR2_LINUX_KERNEL_EXT_RTAI_PATCH))
-
 ifeq ($(KERNEL_ARCH),i386)
 RTAI_ARCH = x86
 else ifeq ($(KERNEL_ARCH),x86_64)
@@ -19,7 +17,6 @@ RTAI_ARCH = $(KERNEL_ARCH)
 endif
 
 # Prepare kernel patch
-ifeq ($(RTAI_PATCH),)
 define RTAI_PREPARE_KERNEL
        kver=`$(MAKE) $(LINUX_MAKE_FLAGS) -C $(LINUX_DIR) --no-print-directory -s kernelversion` ; \
        if test -f $(RTAI_DIR)/base/arch/$(RTAI_ARCH)/patches/hal-linux-$${kver}-*patch ; then \
@@ -31,11 +28,3 @@ define RTAI_PREPARE_KERNEL
                exit 1 ; \
        fi
 endef
-else
-define RTAI_PREPARE_KERNEL
-       $(APPLY_PATCHES)                        \
-               $(LINUX_DIR)                    \
-               $(dir $(RTAI_PATCH))            \
-               $(notdir $(RTAI_PATCH))
-endef
-endif